Can't launch the app: Faulting module path: ~\WindowsApps\Microsoft.DarwinBeta_200.1.27215.0_x64__8wekyb3d8bbwe\AoEDE.exe

Hi everyone!
First of all, thank you to AoE team for this great new game! Please do the same and even more!
I am not sure it’s a correct place for such feedback, so please point the right place :slight_smile:

  • App crashes after playing the third intro (Microsoft studios, forgotten temple and then the main intro).

Event Viewer says:
Faulting application name: AoEDE.exe, version: 0.0.0.0, time stamp: 0x5d4411ef
Faulting module name: AoEDE.exe, version: 0.0.0.0, time stamp: 0x5d4411ef
Exception code: 0xc0000005
Fault offset: 0x000000000023e84a
Faulting process id: 0x135c
Faulting application start time: 0x01d54d6f8540b2cd
Faulting application path: C:\Program Files\WindowsApps\Microsoft.DarwinBeta_200.1.27215.0_x64__8wekyb3d8bbwe\AoEDE.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.DarwinBeta_200.1.27215.0_x64__8wekyb3d8bbwe\AoEDE.exe
Report Id: a78f2b10-8e0b-4475-9a68-2e1e324c3491
Faulting package full name: Microsoft.DarwinBeta_200.1.27215.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

DXdiag here

1 Like

I have exactly the same error. What to do?!

Could you guys first check if Microsoft Game Services for Xbox is installed?

Open Edge browser and paste the link below into the address bar.
ms-windows-store://pdp/?productid=9MWPM2CQNLHN

Yep. This one app already installed. Still nothing.

Of course it’s installed! I can play AoE DE

Problem ONLY with AoE DE beta

Because I upgraded to 1903 today and it wasn’t installed by default, only after running Microsoft Store updates. Maybe the problem is that the AOE DE beta can’t run next to the already released version?
Not sure about that though.

Do you also have the already released (current) AOE DE version running?

EDIT: Don’t bother. I just installed the AOE DE beta and it does work fine for me.

The error means actually access denied.

Do you use additional antivirus applications on your system?

Bitdefender Free, tried with out - same issue.

You mean complete removal, a reboot and then start AOE DE beta again?

Did you request the beta on a alternate MS account from which you bought the AOE DE?

If so, you’ll need to sign on in MS store and run the beta with that account or add it as additional user on your system.

Just to clarify the situation:

  • It’s the same account as I’ve used for registration for beta testing
  • there is no extra Antivirus or any other software. It’s clean windows.

Still, no idea what to do…

Same problem here. And I also can’t even delete it now. Don’t know why.

If it’s a clean Windows and you did perform a fresh USB boot reinstall with release 1903, did you also re-enable DirectPlay afterwards?

image
Direct play didn’t help.

I hope you didn’t forget to reboot after enabling.

Please try the following PowerShell commands (copy and paste as one line).

  1. Right click PowerShell and select the Run as administrator option.
  2. Type in the following command and press Enter (will reinstall all base packages):
    Get-AppxPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
  3. When finished type the following and press Enter (to reboot).
    shutdown -r -t 0

Hi again and thank you for your generous attempts to help, but:

  1. yes, I did a reboot
    2-3) didn’t help also
    There is something with the rights for the game’s folder. But i don’t know what exactly.

Thank you again, but I am giving up. I will wait for a more stable release.

PCS70 user is engaged in flood, spam random advice. It seems he is not trying to help, but just wants to make a lot of messages and get a reputation.

You are indeed correct about error code 5 being a permission denied error.

If it got to do with permission I would check by adding a new local administrator account or add your MS account as user to sign in on that computer.

This trick might help in your case too.

Enable the local built-in administrator account, sign in to that account and try to reinstall and run the game again.

  1. Launch CMD with elevated permissions as administrator and type:
    net user administrator /active:yes
  2. Sign in to the administrator account. Open Microsoft Store and sign in with your Microsoft Account. Say no to converting / migrating your local administrator account with the just signed in Microsoft Account. Click ‘…’ in Microsoft Store and ‘Downloads and updates’. Click on ‘Download updates’. Install Xbox Insider Hub, Xbox Companion-console, Xbox Gamebar, Xbox Game Services and try to install the game again.
  3. After testing to disable the local administrator account again type from an elevated administrator CMD prompt: net user administrator /active:no

I have installed the game today after upgrading to 1903 yesterday. No issues at all, except for the flickering of the intro.

It’s definitely not random nor spam. I don’t care ■■■■ about reputation.