Can't play at all, Game crashes at Launcher & can't reset (Steam), tried everything possible

Game Version:

  • **Build version: 101.101.36202.0
  • **Build config: Final Steam D3D11, built on WORLDSEDGE02, at 2020-03-25T11:17:46
  • **Platform: Steam
  • **Operating System: Windows 10 Pro Version 2004 / Build 19041.172
    This is actually a fresh Win10 install since I upgraded my PC (gfx card & Win10) just to be able to play this game :< system in generell running well without any hiccups, no memory problems in RAM or SSD/HDDs


Intel Core 2 Duo E2140 Allendale @3.2GHz
4GB DDR2 RAM @960 MHz
Radeon R9 290
Win10 on SSD, Steam & Game on big HDD (E:) and lots of memory for Pagefiles etc, tried automatic at first and now using this configuration:


Always crashes at Launcher / Splash Screen after 1-2 seconds, log file stops here:
Initializing Network speed Data
Exception type 0xc0000005 occurred at 00007ff617c8e580
Writing out log

Reproduction Steps:

Here’s how to reproduce the problem:

  1. ???..start game on my computer :wink:
  2. game crashes at launch
  3. be angry
  4. spend some more hours on surfing the web for other workarounds you haven’t tried yet
  5. repeat


logfile 2020.04.14-20.21.58.txt:
I can see the problem is in the ret of NtGetContextThread in WinDbg but don’t know the details to dig deeper on this.

Workarounds and fixes I tried without ANY success:

-) no Antivirus or Firewall except for standard Win10 stuff where I’ve added exceptions in both programs for incoming/outgoing and scan exemption for Steam as well as AoE2HD folders & exe
-) Uninstalled, installed, rebooted and tried launching with every single but also any combinations of x64 VC++ redist 2013-2015-2017-2019. In AoE2HD folder, version 2017 x64 14.15.26706 resides which I also tried
-) deleted all files and folders in game root folder except Docs, resources, and widgetui. Then pressed Verify and it re-downloaded and installed those parts. Tried Verify on multiple other occasions also
-) Tried offline mode / with and without Steam etc
-) Tried compatibility mode Windows 7, 8, with Admin, without Fullscreen, with DPI reduction, etc
-) SkipIntro, NoStartUp (separately & combined), no Steam Overlay
-) display & keyboard language settings EN-US
-) attach to task bar
-) changes to local security policies (enabled some user account control options)
-) Push To Install Service & Xbox Services activated
-) enabled full telemetry diagnose data submission
-) no irregularities in Event Viewer
-) sfc /scannow, chkdsk of all drives, memory test is okay
-) reinstall DirectX
-) use graphic settings in Windows to try settings high performance, low performance, auto for AoE2HD_s.exe
-) newest updates and everything for Windows as well as for drivers
-) file execution protection: tried to add exemption in Windows for AoE2HD_s.exe and Steam but both were not possible, tried with/without XD bit deactivated in BIOS
-) Can’t reset game in Windows settings (no button for that), I guess due to the Steam version :frowning:
-) deactivating audio and network cards in device manager as well as BIOS
-) deleting all smaller and more configuration-like files (json, vdf, cfg, etc) from AoE2DE folder and re-downloading them using Verify
-) clean Windows boot
-) various page file configurations
-) uninstall & reinstall Steam and restore (copy) Game folder
-) about anything else I could have possibly thought of, tried about 20 hours in total now and i’m not exactly IT illiterate.

I’m stumped, really hoping someone can look into that, I’m fed up with this needless to say.
If at least the reset game thing was an option, that would be a workaround for the time being :frowning:

Nice report :wink:
There was a problem with the game when it was on a partition other than C:
Is it somehow for you possible to move it to C:?

Another approach: The error says something about the network manager - if you have the time and knowledge: Can you create a wireshark dump while starting the game and search in it for Microsoft Servers (IP is usualy 52.*.*.*)?
I had an issue there with https and an invalid root CA (GoDaddy G2).

1 Like

Thanks for your reply.
Well my C: is only about 30gigs since I’m using an old small SSD for Sys and have everything else but critical programs on other HDDs.

Exactly, that network manager thing has got me pretty weirded out. I could not find anyone else who had this problem in forums or the like so far :frowning:

I can try the wireshark thing, haven’t played with that tool for almost 10 years but it’s somewhere in the back of my head I think :wink: (if i’m not mistaken, it was still called Ethereal back then ;))
But I tried this online, offline, with my web2go usb stick and my phone USB tethered and even with all NICs disabled in device manager and removed/disabled in BIOS and it was still the same so that’s kinda strange. I do get https issues sometimes in Edge with some servers tho. Can you just give me a further hint on the https/CA thing, what to look out for? Thanks!

Also you don’t happen to have a possible workaround to re-initializing/resetting the App if it’s the Steam version? It seemingly is only possible for the Microsoft Store version so as said I can’t play at all since even that workaround is not available.

This is still a current issue after the latest updates and everything. Steam tried in Beta mode too. Added some certificates with @Pihaar1995 's help. Unfortunately nothing worked or produced any difference.
Still crashes after launcher splash screen with the three faces for some seconds and last log entries:
Initializing Network speed Data
Exception type 0xc0000005 occurred at 00007ff6052c7480
Writing out log

Ok so here we are, 2 months later and just by coincidence I could fix this problem today :smiley:
It turned out to be a Steam problem. Steam Support was not able to help in the past weeks. I just tried again today because I thought if my logfile ends at “Initializing Network speed Data” which usually is followed by sth like “This Steam account 12345678… is online” it seems to be a Steam issue. Furthermore I was having black screens only in the Steam Store and Steam Browser, as well as the Friends & Chat window in the application.

I tried a lot of stuff in the past weeks already but what did the trick seemingly was Fix #1 from this site -
It should already tell you sth if a partition wizard site has better workarounds for an application than the official support :wink:

It recommends just deleting everything in the Steam folder except for steamapps, Userdata, Steam.exe and ssfn files. I moved all other files to a different directory for backup and just left these in the Steam main directory. Then started Steam again and it starts updating because most of the application is missing of course. It reinstalls and suddenly, the Steam Browser and all the things that didn’t work before were working :slight_smile:

First try to launch AoE2 DE and it fires right up - yaaaay! :smiley: