Can't play the game anymore - wrong version

Hi everyone,

As everyone knows, we had to reinstall the game few weeks ago to be able to play, which I did after checking my Windows was running the 1903 version. After that, I was able to play, play with my friends, etc, on the 28529 build.

However, two days ago I wanted to launch the game, but it wouldn’t launch. I tried many times in different ways but it just couldn’t launch. So I decided to uninstall it and reinstall it through the Microsoft Store. Unfortunately, everytime I install it through the MS Store, I get the old version (27374). I tried to click on the “get new updates” button in the MS Store but nothing… And I checked my Microsoft 10 version and it’s the right 1903 one still.
It’s also to note that when I search for “Age of Empires” in the MS Store, go on the game page and click “install”, it doesn’t install. So I go to my games library in the MS Store and install it through there (the game logo is dark and white).

Does anyone know what could be the issue or how to fix this? Thanks!

Hi @NastyMind24, Please see the topic linked below for info about how to upgrade your game client to the latest version.

Upgrading to the latest Age of Empires: Definitive Edition (Windows Store)

The dark and white game in your library is the old client which does not have the latest features, including crossplay with the Steam version.

Hi @RadiatingBlade, I know all of this. Please re-read my message. I can’t get to download the new client, because each time I click on “install”, 1 second after I get the “your game has been installed” message, which is not the case.

Did you try the steps mentioned here already?
https://support.microsoft.com/en-us/help/4027498/microsoft-store-fix-problems-with-apps

1 Like

My apologies. I scanned through your post without reading it carefully.

Yes, still got the same problem :frowning:

@RadiatingBlade all fine, no worries :slight_smile:

Did you also try wsreset method?

You could also try the pieces of PowerShell script in the other thread that tries to reregister it from the WindowsApps cache because you had the new version installed already.

@PCS70 Do you mean to run PowerShell in administrator and do that?

$p = @("Darwin","MSDallas"); $w = "$($env:ProgramFiles)\WindowsApps"; $p | Foreach-Object { Get-ChildItem $w\Microsoft.$_* }; $p | Foreach-Object { Get-ChildItem $w\Deleted\Microsoft.$_* }

If yes, then here is the result:
Répertoire : C:\Program Files\WindowsApps

Mode LastWriteTime Length Name


d----l 13/10/2019 16:14 Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe

I also did try the command prompt to stop Windows Update, reboot laptop and then try again on MS Store and nothing.

That one only list the folder names. Could you try this one to reregister?
You need to launch PowerShell as administrator.

# this script must be launched as administrator with elevated permissions
$p = @("Darwin","MSDallas")
$r = @(); $w = "$($env:ProgramFiles)\WindowsApps"
Foreach ($i In $p) {
   $f = "Microsoft.$($i)*"
   $r += Get-ChildItem $w -Filter $f
}
$r
ForEach ($i In $r) {
   $n = $($i.Name).Split('_')[0]; $c = Get-AppxPackage -Name $n
   If (!$c){
       Add-AppxPackage -DisableDevelopmentMode -Register -Path "$($w)\$($i.Name)\AppxManifest.xml"
   }
}

So here is what I got (an error message apparently)

Répertoire : C:\Program Files\WindowsApps

Mode LastWriteTime Length Name


d----l 13/10/2019 16:14 Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe
Add-AppxPackage : Échec du déploiement avec HRESULT: 0x80073CFF, L’installation de cette application requiert une
licence de développeur Windows ou un système compatible avec le chargement indépendant.
Le déploiement du package Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe avec l’origine du package Unsigned a
échoué, car aucune licence valide ou aucune stratégie de chargement indépendant n’a pu être appliquée. Il se peut
qu’une licence de développeur (http://go.microsoft.com/fwlink/?LinkId=233074) ou une configuration de chargement
indépendant d’entreprise (http://go.microsoft.com/fwlink/?LinkId=231020) soit requise.
REMARQUE: pour obtenir des informations supplémentaires, recherchez [ActivityId] 42c662dc-9433-0002-ceb6-c6423394d501
dans le journal des événements ou utilisez la ligne de commande Get-AppPackageLog -ActivityID
42c662dc-9433-0002-ceb6-c6423394d501
Au caractère Ligne:11 : 8

  •    Add-AppxPackage -DisableDevelopmentMode -Register -Path "$($w) ...
    
  •    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    • CategoryInfo : NotSpecified: (C:\Program File…ppxManifest.xml:String) [Add-AppxPackage], Exception
    • FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

Are you using Windows 10 Home edition?

Although they promised one Windows there are a lot of differences between more versions than ever.

You could also try this one to fix issues with MS store.

Launch CMD as administrator and type the following:
Dism.exe /online /Cleanup-Image /StartComponentCleanup

After the command has finished reboot and try again to install from MS store.