Can't upload mod (experimental balance data mod)

I’ve made an experimental balance mod, but I can’t upload it.

My system is set up a little weirdly, which stops me from logging in on xbox live via AOE2, so I’m trying to upload it via the website.

But I get the error message
“Error submitting mod! Please verify your data and try again.”

The mod runs fine on my computer.

Does anyone know what the problem might be? Can anyone help? Is the zip file likely to be the problem, and if so does anyone know what the zip file ought to look like?

PS: the design documents of the mod (with a complete list of changes) can be found here:

1 Like

@DodoNotDoDo Your help is needed


Were you uploading with the account you’re logged on to the forums with? I don’t see any failed attempts for that account, so it must have failed early in the process. If you can confirm the account used, the name of the mod and the date and time of your last attempt, I can check the logs for further info on why it might be failing.


Tried it again just now. 16:35 GMT 01/09/20 . Account name is indeed “TougherTrack508”. Mod name is “PCs Experimental Balance Mod”.

Hmm, I just checked and I see no record of the attempt at all. In that case my guess would be an authentication issue, but hard to say for sure. If you can try again, just before clicking submit, hit ctrl+shift+i to load up the browser’s dev tools. Switch to the Network tab. Click the Preserve log (or similar) checkbox. Then click the submit button on the form. You should see a request made to submit the form and it will likely show as red. Click that item and see what it shows for the response. Primarily I’m interested in the status code and anything in the response tab. That might tell us something.


{“error”:{“code”:“UnsupportedApiVersion”,“message”:“The HTTP resource that matches the request URI ‘’ does not support the API version ‘1’.”,“innerError”:null}}

I think I successfully uploaded it my going via Firefox. If I don’t add anything else the problem is solved :smile_cat:

1 Like

It’s not Possible to upload via Game Mods-> my Mods(Lokal Mods import)? If i click on it the game will be stop…

Kann man die Mods nicht über das Mod Menu im Game unter Meine Mods hochladen(Lokale Mods importieren)? Das Game bleibt einfach hängen…

I couldn’t. Maybe we’ll hear from someone who could.

BTW, I think I should add I am grateful to @DodoNotDoDo. I only tried Firefox because I realised it was an API issue.

1 Like