Change Object Attack - attack/armor class stuck at 0

When I’m trying to use to use the Change Object Attack effect, any attempts to modify the “attack/armor class” to a different number field will always result in the value reverting to “0” when I select another trigger or effect and click back to this effect. My understanding (or at least assumption) is that this field is where you are supposed to modify the attack type based upon its designated number in the Genie Engine (1 = inf, 2 = turt ships, 3 = melee, etc.). Is there something I’m doing wrong?

Edit: Post has been relocated to the Report a Bug forum

Can you show an annotated screenshot? It’s tricky to visualize.


I complete the required fields for this effect.

Then I click elsewhere in the list (in this case, I clicked on the Condition item).

Upon going back to the effect listing, it has now reverted to 0.

Hope this helps

That’s really weird. I would probably create a bug report for that, because I’ve never seen any behavior like that.

Alright, thanks.

I’ve tried doing basic troubleshooting like validating files and whatnot but nothing has worked.

I have seen the same. It goes back to “0” every time. Think it’s since the new dlc has been published

thanks for all your reports. This issue is being tracked already

The Bug ist still there after the last update!

This issue is really annoying and exists every time when you click the effect again, so I abandoned using it to modify unit armor and attacks and using script call instead.

Please fix it as soon as possible,so upset for it!

As I understand it, Update 63482 noted that this issue was supposed to be resolved, but it still persists for both the Change Object Attack and Modify Attribute triggers. Is this occurring for anyone else?


Yes, It was kind of sorted out in between the last updates. Like, the values entered as attack/armor types code (3 for range, 4 for melee etc…) always reverted to 0, but the correct value entered was still effectively applied, and the attribute would be modified correctly in-game.
Then after the very last patch it went back to prior issue once again.
Hope this gets fixed for good soon.

1 Like

Gotcha thanks. Was kinda driving me insane since I thought it had been permanently rectified.