Chinese Mastery (Xbox Series X) Challenge 9...bugged!


I wasnt sure if this has been mentioned but Challenge 9 “Path of the Spirit” is bugged on Xbox in the Chinese Mastery challenges.

I have attempted to use the old method of building around it. No luck. I have tried building it away from all other buildings. No luck. I have tried progressing to Age IV and then researching them all. Nope. I tried building the landmarks in a specific order. No luck. I tried creating the units, then upgrading them through the landmark. No success. It appears to be bugged as hell.

From what ive seen off one forum for PC users reverting to an old update saves the day. Can something similar be implemented on Xbox please?

I hope im not the only suffering this on console, im aware a few PC users are affected but am yet to see console related issues around this. If anyone has a fix, suggestion or to tell me im doing it all wrong, im open to all.

~from a new forum user to AOE IV


I need some help here. I have EXACTLY the same problem ! I did like 10 games researching everything possible even from other buildings. The masteries won’t unlock. I try this for 2 days and i was becoming crazy as chinese is my main civilisation and i can’t even bring it to masteries 15 because of that bug. I hope there will be some patch to fix it because it is very annoying. Thanks for the topic man i hope we find a solution for this masteries on xbox !

1 Like