Coming Content Updates for Age of Empires: Definitive Edition - Age of Empires


#21

Pathfinding is from the stone age! Really bad…
I will wait for the AoE 2 DE, this one need a lot of worl see you in 20 more years ppl.


#22

Too much lag.


#23

Is this still not available in Canada? Whats going on?


#24

Does this Definitive edition have all All the Age of empires (1,II, & III)? Really i’m only interested in III, so does this have III or naw?


#25

@Shneider177 said:
Does this Definitive edition have all All the Age of empires (1,II, & III)? Really i’m only interested in III, so does this have III or naw?
No, is a remaster. in this case from the 1. Then they will make a remaster of 2 & 3.


#26

I can’t even buy the game (from Sweden). I have ordered a game code from a Swedish Store, they said there is a problem connecting to the MS code servers. I tried to order it directly but Microsoft Store asks for an American Credit Card (which I don’t have!). I wished buying AOE DE was very smooth and not so many practical problems! My excitement starts to wane actually!


#27

The game wont run for me. When I press play the game closes down. I looked on the support page and did everything it said to do, but still no luck. (Australia - Microsoft store)


#28

Can you only install on windows 10 or is the game compatible with Windows 7


#29

@pyrophil19 said:
Can you only install on windows 10 or is the game compatible with Windows 7

win10 exclusive.


#30

@Augustusman said:
@pyrophil19 said:
Can you only install on windows 10 or is the game compatible with Windows 7

win10 exclusive.

Pfff cheeky Microsoft. I had windows 10 free upgrade after having to wipe my pc due to a virus they wanted me to buy windows 10 this time. No chance screw greedy Microsoft won’t bother with the game


#31

this game isnt working will sombody please make a statement of what the fuck is going with this garbage !!!


#32

Bom dia…
Estou iniciando o jogo e o mesmo não carrega. Alguém sabe alguma solução?


#33

I have tried re installing 4 times now and still doesn’t work WTF is happening, I have tried the basics. This is a huge joke. You pay for a game and expect the support behind it. HOW the **** do you fix this issue of not loading into the game. Menu works Fine, enter game lobby under multi-player but cannot join games. Same with cam mode doesn’t work.


#34

Hi, your game is not even launching. I’m very frustrated, but I could be patient. Do y’all have a customer support dept. we could ask for help?


#35

Guys, REALLY? Everything in this game is blocking another thing. Workers block by tree, workers block my other workers, workers block by building , soldiers block by other soldiers when running, soldiers block by other soldier in fights, DID YOU ACUTALLY PLAY THIS THING BEFORE U BRING IT OUT??? GOD damn , poor age of empires that have u as dev. ( sry but this game is useless for now )


#36

The game does not start for me, please fix this.


#37

@xwsn said:
The game does not start for me, please fix this.


#38

@SinusMiniKing said:
Guys, REALLY? Everything in this game is blocking another thing. Workers block by tree, workers block my other workers, workers block by building , soldiers block by other soldiers when running, soldiers block by other soldier in fights, DID YOU ACUTALLY PLAY THIS THING BEFORE U BRING IT OUT??? GOD **** , poor age of empires that have u as dev. ( sry but this game is useless for now )


#39

@AndrewMuscle8 said:
Hi, your game is not even launching. I’m very frustrated, but I could be patient. Do y’all have a customer support dept. we could ask for help?


#40

It works on My Machine…