Connectivity Issues - "Searching for Games" Spin

Hey all, my lobby for multiplayer games just keeps spinning at “Searching for Games”. Was hoping someone would know a fix?

Hi @FrenchFantome, Which Age of Empires game are you experiencing this issue with finding multiplayer games? Is it Age of Empires II: Definitive Edition, Age of Empires: Definitive Edition or another Age game?

Age of Empires II: Definitive Edition!

exact same issue. Games wont show on lobby browser.

Game Version:

  • Build (####)
  • Platform: Steam


Can connect fine to the multiplayer section of Age of Empires II: Definitive Edition. I can even search for and join ranked games. Unfortunately, I can’t see any of the unranked lobby games. All it shows me is the “Searching for Games…” message.

Reproduction Steps:

  1. Explained above

1 Like

same problem here using xbox game pass

Same problem.

Latest version
From Chile

1 Like

Hi all.
OK, SO NO HATE - I know that you know abiut the bugs and that the devs know about it, BUT I wish to share my pain with you guys. Plus I wanted to ask if people have the feeling that once a patch fixes something 2 more new bugs appear. LOL
LOBBY not working for me is something I got used to by playing ranked. They should fix the lobby ofc.
BUT Id like to share this :
1/ I am sad it does not show KILLs/Deaths stats. This is relatively new, so frustrating…
2/ I hate it when villagers get stuck near a lumber camp and it is not even counted as an idle villager. I almost never had this s*** in AOE2 Conq.
3/ I have a bug when I send them to make 5 houses in a queue and they just stay there and do not even start the first one, then the player gets housed forever
4/ I have a problem with elo points, do you guys see this often ??? This is new for me. I lost a game and I did not lose points today… This sucks. I win it sometimes and still NO points. Just nothing … WTF?
5/ I have a bug where 6-7 are supposed to build a new camp at the woodline and then just half of them build it, the rest just stay there but are not shown as idle… LOL :frown:

The game is just not a week old, WTF is going on now ???
I d like to introduce a new taunt because of this :
D14 it has to be
/ "Devs, please start the IT game aleady ! " /

How do you feel about the game after the last fixes ?

Hello everyone! Thank you for posting about this issue! A few questions about this problem:

  • What platform is everyone playing on?
  • Is Enable Crossplay checked in your settings menu?
  • Are you able to find games if you do not have custom filters set?
  • Does signing out of Xbox Live bypass the error?

Let me know if any/none of those work for you! We are tracking this issue internally, but any information you provide will help us dig into the issue!

Thanks again!

1 Like

Hey GME,

  • Steam platform, though as you can see above from others it doesn’t seem limited to just Steam.
  • Enable crossplay is checked, please see screenshot above for the confirmation that crossplay is enabled at the bottom of the screen
  • I’m unable to see any games in the lobby, regardless of any filters whatsoever.
  • I just tested signing out of Xbox Live - this does indeed bypass the error!

Let me know if you need anymore information and thanks again for the response!


  • steam
  • yes
  • No.
  • Yes! Logging off Xbox live fixed it. thx
1 Like