Constantly crashing since day 1!

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Version 101.101.51737.0 7126076
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
The game crashes about 1 time out of 3 on every computer I have ever run it on! No warning - just kicks me back out to the desktop. Occasionally, on my laptop, it freezes and I have to restart my computer but it happens constantly no matter what I’ve done for troubleshooting - updated drivers, Windows patches, increased virtual memory, patched the game, etc, etc, etc…nothing has ever stabilized this game since the day it was released.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 25% of the time / matches I play (SOMETIMES)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Run the game - single play or multiplayer
  2. Play it for about 20 minutes
  3. Watch it crash

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
It was supposed to NOT crash

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.
There is no screen shot - unless you want a picture of my desktop - there is no error, no warning

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

*Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

1 Like

Well then you have at least 2 computers, where it works properly.

1 Like

I have exactly the same issues, but not only with crashs to desktop.
Additionally I have fps performance and connectivity variating between each machine.
I tried using differend hardware, reinstalled the os, changed .net framework and msvs libraries – i can’t find out what’s wrong exactly.
The only thing I know is that many AMD graphics users have a terrible frame time bug.

Hey!
Thanks for the report, but to properly investigate your issue we need crash logs and not save games that then crashed. Those are located here C:\Users<USER>\Games\Age of Empires 2 DE\logs, also helpful would be .mdmp and log files (sync logs will have this format 140673-2021 .06.08-13.35.20-sync.txt and crash logs will be the normal logs with the date and time on the filename
Also if you want to help us further try to reproduce your crash on our
Enhanced Logging build? The steps are in this post: 📌 [HOW TO] Use the Enhanced Logging Build to generate Networking Logs (Disconnects)
That log file contains information which will help us to see exactly why the game is showing you this message, instead of the list of games.

Sorry, the requirements weren’t that clear. I have looked through this folder and can’t find anything that ends with “sync.txt” but I did find other files that seem related to my last crash here:

I will check into the enhanced logging…

This seems more relevant to the issue though - the windows logs always show that the virtual memory gets exhausted when the game crashes. I have increased the size of my virtual memory to several times the recommended amount but it doesn’t seem to be helping. This also happens on 2 other computers that I run the game on - consistently.

In case the screenshot isn’t clear, the text is:
Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: AoE2DE_s.exe (7784) consumed 12642955264 bytes, mstsc.exe (5260) consumed 663003136 bytes, and chrome.exe (11032) consumed 497119232 bytes.

@RedHagar thanks for the files submitted, from the .mdmp file it seems like the crash could be related to a bad mod, could you try to play without mods and see if you still get the crash? You can disable them all and then try one by one to find out which one is causing the issue

As far as I know, I do not have any mods enabled, nor have I ever used them. As I said earlier, this happens VERY regularly on all 3 of the computers I use…usually every 3 or 4 times I run the game. It seems to be doing something strange with virtual memory. I have to reboot and run it again from the autosave. Then it will be fine for 2 or 3 games until it crashes again. I have cometely given up trying to run multi-player games.

If the game is still crashing after following those steps, then it would be very helpful to contact our Support team Submit a request – Age of Empires Support so we can investigate what is happening. Please include your DxDiag and crash logs. Steps to find those are here: How to find information for troubleshooting with Support – Age of Empires Support