Crash a few minutes ingame


Since yesterday I have crashes after a few minutes ingame. Before it was just a small lag that I could live with but now the game is crashing back to desktop. Any idea of what that could be? I am getting tired of this since AOE2 has similar issues lately. Everytime there is a new update, both games have more and more issues. Do the devs even make some testing and QA before they release updates?

Can you send the logs please ?
C:\Users\Username\Games\Age of Empires 3 DE\Logs

Age3Log.txt (4.4 KB)
Age3SessionData.txt (171 Bytes)

Also tried to reinstall the game but it did not help

By any chance, are oyu using a AMD GPU?
WOuld be lovly to get some PC specs here :slight_smile:

Yes AMD Radeon r5 of i am not wrong. It is strange since both aoe 2 and 3 worked fine like a month ago but now both games are crashing all the time

AMD has a series of crashing drivers
Downgrading the drivers might solve the issue

Any idea how I best do that? I checked the device manager and tried to roll back a driver on the GPU but this function was blocked for some reason

You can deinstall your current driver. Maybe a fresh install can also help.