Crash in every game when selecting explorer

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 43871 without African Royals expansion
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The game freezes and then crashes when selecting an explorer unit.

:arrow_forward: FREQUENCY OF ISSUE

100% of the time in single player skirmish, haven’t tried in multiplayer

:arrow_forward: REPRODUCTION STEPS

  1. Start a single-player skirmish (I tried British, Dutch, Chinese, standard maps, random opponent, easy difficulty).
  2. When the game starts, click the explorer or envoy.

The game freezes for 1-3 seconds and then crashes to desktop without an error message. The explorer selection sound is briefly audible.

:arrow_forward: EXPECTED RESULT

Explorer unit is selected, game continues.

:arrow_forward: IMAGE

There is nothing to see. The game is frozen and then crashes to desktop.

:arrow_forward: GAME FILES (SAVE / RECORDING)

Age3Log.txt (3.3 KB)
Record Game.age3Yrec (2.2 MB)
Note: This recording shows as invalid in the game, probably because it crashed while recording.

Same for me…all have been in the casual lobby. No “lost connection,” no lag…just dumped to desktop. Three times.

Do you also not have the African Royals expansion? I’m wondering if that’s the reason it’s not been noticed so far.

Same issue for me and I have the African Royals expansion pack if that helps.

I have the AR expansion

well, it also happens in “Skirmish” mode as well, lol

Try unselecting mods. I updated the mods and it still crashed but the game will play if all mods are unselected.


Always, after game update, unselect mods !
They wont work, and just make you a hard life.