Crashing in imperial age, every game

Hi, my game keeps crashing in imperial age, every single time. I do not have any lagspikes prior to the crashes. Just sudden crashes to desktop with no error message. I play 3v3 or 4v4 with friends and this make the game simply unplayable. I have a good enough computer and have 1250+ in the benchmark test. I’ve been googling and reading the forums trying different things. But our last 10 game have all ended with me crashing. I’ve even reinstalled windows10 on this computer, still same problem. Have checked for outdated drivers, can’t find any.
Processor: Intel® Core™ i7-4770K CPU @ 3.50GHz (8 CPUs), ~3.5GHz
Memory: 16384MB RAM
Card name: NVIDIA GeForce GTX TITAN X
edit: using xbox game pass.

Have you tried reinstalling? Also try unsubscribing from mods if you have any.

I’ve reinstalled, but apparently small tree mods and improved grid mod was still running. The worst thing is this hasn’t happened in offline games. And I wouldn’t want to ruin any more online games. But guess I can try online without the mods later today.

Okay, sorry that it took some time to get back to you guys, had some other things i had to do. I disabled/unsubscribed to all mods i had running. And yet again the game froze at 40+ minutes.

Went to check the event viewer and found an error this time.
Faulting application name: Xbox.exe, version: 2003.1001.4.0, time stamp: 0x5cee7b71
Faulting module name: Windows.System.Diagnostics.dll, version: 10.0.18362.836, time stamp: 0x863a6170
Exception code: 0xc0000005
Fault offset: 0x0000000000009c59
Faulting process ID: 0x2064
Faulting application start time: 0x01d633fed8f2e12e
Faulting application path: C:\Program Files\WindowsApps\Microsoft.GamingApp_2003.1001.4.0_x64__8wekyb3d8bbwe\app\Xbox.exe
Faulting module path: C:\Windows\System32\Windows.System.Diagnostics.dll
Report ID: 263fe939-7519-46ed-a758-4bf56ff3ecaa
Faulting package full name: Microsoft.GamingApp_2003.1001.4.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: Microsoft.Xbox.App

Tried googling, but can’t get a solution.
edit: did a sfc /scannow, found no problems.