Create CLAN issue

Hello,

Your CLAN page has some issues.
It’s not possible to create a new clan because of the field CLAN NAME is not accepting any name.
Doesn’t matter what name you put there, the message “Name already in use” is showing all the time.

I tried even with random words like “jonsadkjandkjasnd” or something like.

Please, fix it.

Regards.

@DodoNotDoDo Would you please look into this report?

I’ve passed the note along to our web team. We’ll take a look and see if we can identify the problem and get it fixed up!

1 Like

This should be fixed now. If you continue to experience issues, let us know!

1 Like

Hi @DodoNotDoDo, I am still experiencing the same issue with clan creation. I tried to create a clan since early June. Until now, I still cant create a clan for my team. I highly appreciate if you could take a look and get it fixed.
Thank a lots!

Please try again now. Looks like a url got changed inadvertently.

1 Like

@DodoNotDoDo Thanks for your reply. I tried and still could not create clan. I hit the “submit” button for mutiple times and nothing happened. On the other hands, the “cancel” button works, but not the “submit” button.

Different issue than I thought originally, sorry. It should work now.

1 Like

Hi @DodoNotDoDo, I can click the “submit” button now, however, it keeps appearing “Error submitting clan! Please verify your data and try again”. I dont know what is wrong with my submission.


Here are the screenshots of my form. Could you please tell me what errors I made here? Your help is highly appreciated. Thanks

Can you try again now? It was an error happening on an Xbox Live service that should be fixed now.