Create Clan

I can’t create a clan … the error is “Error submitting clan! Please verify your data and try again.”

Help me Please!!

This should work again now. If you run into further issues, please let us know!

Hey Bro! Still not working : ) … I enter the correct data but I can’t…
What do I do?

We pushed out another update. Let me know if you’re still not able to create a clan.

Definitely still cannot create clans. I posted in Discord about this as well.

Errors received:
“Error submitting clan! Please verify your data and try again.”
“A simultaneous request took precedent.”
“X-requestinguserid headers is missing.”

I get a different one almost every time.

Troubleshooting steps taken:

  • Logout/back in
  • Close browser/reopen
  • Make sure you are logged in to Microsoft and not Steam (unsupported)
  • Leave various fields blank/fill all fields/etc.
  • Change browsers (Chrome, IE, Edge, Safari, Firefox)

image

Found out until you make a comment/forum post and earn the “Basic” Trust badge you cannot create clans.

This should really get a disclaimer at the top of the create clan tab or be removed entirely.

This is just a coincidence. There’s no tie between clan creation and forum activity.

I checked the logs and it looks like the Xbox Live service we use was having some kind of issue around the time it looks like you were trying. Sorry for the extra work to get a clan created!