Debilitating frame skips occurring 1-2 times every second

:arrow_forward: GAME INFORMATION

  • Build: Latest (101.101.40220.0 5438859)
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Poon

:arrow_forward: ISSUE

I’m not sure when exactly it started, but within the past week or two my game has been having some serious problems with small stutters—about one or two every second—regardless of graphics settings, and even on the main menu. I’m pretty sure it’s more of a frame skip than actual lag, because I can continue to move my mouse during the skip, but units and camera movement will freeze and then catch up. These skips were not present a when I first started playing AoE2 near the beginning of the year.

I’ve followed all of the optimization suggestions (, tried moving the game to my SSD, and doing a clean reinstall, but it still hasn’t returned to how it’s been working previously. I’m not sure where to go from here, so I hope someone out there has a suggestion or two!

:arrow_forward: REPRODUCTION STEPS

Here’s how to reproduce the issue:

  1. Open the game

:arrow_forward: IMAGE & ATTACHMENTS

This is an issue that I have encountered sporadically. It seems to happen at random, but it seems like for you it is happening in every game? Maybe posting your system specs will also help?

Yeah, it’s been happening every game, as well as in the main menu (the particles that fly around tend to stop and start). Here’s some computer stuff if it helps, but to be clear, the game runs identically whether it’s on the worst graphical settings or the best:

Processor: AMD Ryzen 5 3600X 6-Core Processor (3.79 GHz)
RAM: 16 GB
Graphics Card: NVIDIA GeForce RTX 2060 Super

Your specs are definitely more than adequate. I am not sure why the problem persists even after a clean install. Have you tried both offline and online matches?

Both online/offline matches perform similarly, so I’m fairly confident it’s some weird hardware/software issue on my end. But the game was running just fine a few weeks ago, so maybe something in the recent patch disagrees with my computer?

EDIT: I’ve also tried disabling everything from the summer event, as well as all my mods in general, but to no avail. Performance stays the same.

Still troubleshooting this issue. I decided to try to track my FPS and try to correlate it to the frame delay, and although it at first seemed like the FPS was going 100+ every time it stuttered, turning on v-sync did nothing, so I guess it’s not an FPS problem? It very consistently hovers around 60 without too much variation. I also tried a hard reinstall by uninstalling the game and deleting all associated leftover files, but steam saved them and just reapplied them after I reinstalled. Not sure how to get around this or if it even matters.

And some additional info: tried messing with windowed vs fullscreen and watching my cpu(~15-20%)/memory(~1.5GB)/gpu(~15-30%) while playing the game, but nothing out of the ordinary. I did find an older post about an identical issue, but this individual solved their problem by moving the game to their SSD.
Interestingly enough, someone in the comments suggests it’s an issue with amd cpus/nvidia gpus, which is my current setup.

As expected, I didn’t really ever get any support for my issue, but I eventually found a solution. I updated a whole slew of random drivers, including miscellaneous audio drivers, as well as some sort of windows update that didn’t automatically go through like the rest usually do. So to whoever else has this issue, I guess just update everything, regardless of how relevant it seems. AoE2 is super picky about running on anything that is 1-2 weeks too old.