Delhi Units/Villagers Don't React to action

I noticed that when playing Delhi, almost exclusively Delhi, when there’s a battle, my units will not react to my right clicks. For example, a few matches ago, opposing player attacked my villages gathering gold, I tried to get them to stop working and go inside the tower/TC but they ignored me and kept on mining. This also happens a lot when I try to maneuver my Elephants/MaA when attacking their base, they ignore me. I thought that it was that they were stuck near a building for whatever reason, but they completely ignore my right clicking to get them off to safety. I’ve lost a lot of battles or villagers because of it.

Is anyone else having this issue?

I play every civ other than English, and I can’t honestly say this problem happens when using any of the others, only Delhi.



As a Delhi only player myself, I also experience this, not all the time, but sometimes my clicks don’t seem to register with the units. Using hotkeys seems to help a lot, as those always register. Quickly grabbing your units, right clicking somewhere, then holding Shift and right clicking again seems to work flawlessly, same for attacking buildings and stuff, if you want to go through that kind of rigmarole.


I hope in the name of the almighty baby elephant prelate khan that these Delhi bugs get fixed soon.

I’m also a Delhi only player. I played other civs only for campaigns/masteries.


Haven’t tried this, this issue tends to happen at the worst times so I start to spam click for them to get out or engage and they just stay there. The most memorable times this happened for me was when I had over 25 villagers mining gold, and the enemy just got there to wipe them, I tried to get them back to safety and they just kept mining. Enemy wiped them out. Second most memorable was when I had my elephants running through their town, I just needed to destroy the last landmark for victory, elephants completely ignored me and just kept blowing up houses. If it wasn’t because my elephants survived through their last units thanks to my crossbowmen and archers, I would have lost that match. (he was rushing my base too).

I noticed this as well, seems random and only in castle, imperial. But only played like 20 games vs comp with DS

1 Like

Happens to hre as well. Usually on attacks (extremly noticeable for siege units) but I had units refusing to disengange the enemy a couple of times as well, thought there was a taunt mechanic at first.

Not a shift-clicking issue, as should be seen on the landsknecht

1 Like

The last video is exactlyyyyyy what happened to me multiple times!

I stopped playing Delhi and now playing Abbasid, haven’t had any issues with this, yet.

Inb4 its the same type of bug that causes Delhi + HRE Spears to not brace.

Thank you, all. We’ve heard you and are investigating. I’ll leave this thread open—any other details you can come up with to help repro this one would be much appreciated.


Hey Savage,

Happened again tonight, this time I was playing Abbasid. 2v2 (me and hardest AI vs 2 hardest AI - They were French = Yellow and English = Green).

Nagari - Small, Asian Subtropical

Had 3 Mangonels, 2 Springalds, 16 bowmen, 7 spearmen.

Engaged one of the AI near their gold mine, Infantry marched towards their units, Mangonels did not respond, Yellow was above me and green below. I thought Mangonels were out of range, so I moved them closer, but they did not respond. I CTRL+Shift+C to get all of them, I A-Clicked near them, and again, infantry went ahead and moved, Mangonels did not, Springalds shot behind Mangonels. After green was wiped out, I was finally able to move the mangonels and move to clear yellow on top.

I’m going to play a bit more tomorrow, I’ll try to find a way to record the matches without my game freezing (any time I video record, AoE4 just lags out like crazy, even on replays).

Thank you

Thank you for some additional context @BlackBeard0917. We are definitely checking into this.

1 Like