Dropping when playing on Brazilian server

Good day, everyone! We’ve been following the reports on this matter and would like to collect some additional information from those affected. If you are either being forced to play on the Brazil server and/or experience connection issues when you do, please send me a private message if you are willing to generate advanced networking logs for the team. I will get back to you as soon as possible with details and instructions.

Thank you all for taking the time to report this problem, and I look forward to hearing from you!

7 Likes

I really think you need to disable the Brazil server in matchmaking untill you actually find a way to fix it. So many games are ruined, which is ruining the games’ multiplayer population by letting people play on bugged servers cos I don’t think many people are willing to keep queueing after a few drops in a row.

Yesterday I played around 10-ish ranked teamgames, around 2200 tg elo. 4 of those games someone disconnected or dropped early, and all 4 of those are brazilian server. Today i tried 1 game at multiplayer, freeze at loading screen, check which server it is on aoe2net, and yep its the excuse of a Brazil server.

3 Likes

Hi, all. First of all, this bug is super annoying. It is ruining the experience of playing multiplayer with my friends. The description of the issue is the same here, the UI freezes, I cannot move units, select anything, just the song keeps playing.

However, my case is a bit different. I am based in Europe and my 2 friends are based in Brazil.
Sometimes the server assigned is UK and sometimes is Brazil. When the server is UK, the crash happens to one of my brazilian friends. When the server is Brazil, the crash happens to me.

PS: Normally this doesn’t happen in 2v2, only 3v3
PS2: Happens on Ranked Team Random Maps and Lobby too
PS3: There is no log dump or windows event entry when this bug happens.

NEW TEMP FIX

Hey guys, I have a new fix that I’ve played 10+ games on Brazilian server with no drop. If i plug in my Android phone to my PC via USB and enable ‘USB tethering’ it works fine.

PS - I disable 4G data on my phone, so it is still using my home wifi (so it is still using same internet connection/ISP, basically phone is acting as a network card) - leads me to believe that it could be related to my PC network adaptor or it’s drivers (again - only happens when playing on Brazil server).

If you look at aoe2.net comments section, there are many many people complaining about drops and lag on Brazil server…also that a disproportionate number of players end up on that server despite their physical location.

@GMEvangelos FYI might be a solution to tell others until it is fixed.

Having to use phone is not a solution. Not all of us are able to make it work like that.

Also again I got a drop, seems like every 1st game of the day is a drop on the loading screen. And instant loss. And ofc i go to aoe2net and its brazil.

You developers are really giving off an incompetent attitude like you don’t even care, not being able to do anything about a CORE issue, at least give some BAND AID fix like disabling brazil server for the time being. It will probably be a miracle if this gets fixed before september or october.

Why does this happen? The loading screen loading forever, not letting me inside the game.

Today happened 2 games in a row, yesterday only once.

both games in brazil today

2 Likes

I have a solution as well, and I think this is something everyone can use. You need a usb cable which has a micro-usb port on one end and a regular usb connection on the other. These are most commonly found with android devices but you can get them anywhere. Then, just plug the usb side into your computer, and plug this into the micro-usb port:

https://www.argos.co.uk/product/8151937

Let me know how it goes.

1 Like

I am consistently being thrown to Brazil server from Asia which is probably the furthest server considering my location. After some 3-4 mins I drop out of game. This issue most probably came with the new patch, because, the first time I was in Brazil server was 16 days ago according to aoe2.net. Super annoying.

1 Like

I’ve been having the same issue for over 2 months, all on Brazil server and i live in New Zealand.

5 Likes

Ive finally started checking the servers when disconnects happen. Every single time, literally every single time, it’s the Brazil server…

They need to shut it down.

4 Likes

Please devs, at least some response here… it is affecting loads of people

1 Like

Another temp fix for me is that I have a spare network card for my desktop PC, 5 games on Brazil servers today with no drop on that card (still get a some decent lag spikes here and there - but no drop). The card is worse than the one I was using, but at least i don’t get drops.

Makes me wonder if it’s a hardware/drivers thing…regardless, still we should not be getting placed on the brazil server so often.

1 Like

Here you go, the response of a dev:

Another day, same old, same old.

Still the Brazil server on which every single disconnect happens…

1 Like

Thank you all for the reports! The issue of games spinning up on the Brazil server when all participants are in a different territory should have been fixed with Tuesday’s maintenance:

If you are notice that you’re still connecting to the server from an outside region, please let me know so I can follow up on your behalf. If you are experiencing performance issues on the server, please open a new thread to discuss that particular issue in a separate thread.

Thank you all for the reports!

Team games are unplayable right now because at least 1 player will disconnect at a random point in time. This is especially evident in 4v4 games. It happens every game, regardless of server (I have personally seen it happening in almost every game on the US West server).

finally largely improved after getting away from Brazil server!!

1 Like

I’m having this issue quite often, and not just on the Brazil Server, just had this bug ruin a game now on server US East. My internet and wifi did not drop, but I “Lost connection to the server… Attempting to reconnect”

Just remove the bloody server if you cant fix it