Earned XP Not Showing In-Game

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 38254
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
Following the Africa update today, the game is not showing earned XP. I have repeatedly attempted changing graphics setting and restarting the game as this has worked to fix the issue in the past, but no success this time.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Launch a game
  2. Kill anything
  3. Observe no XP icons

:arrow_forward: EXPECTED RESULT

Earned XP should show

:arrow_forward: IMAGE

:arrow_forward: GAME FILES (SAVE / RECORDING)

N/A
*

Heey @stephensundin, thank you for the report. We’re now tracking this issue.

2 Likes

Yeah, I played a game as Spanish last night, had two TPs and wasn’t getting XP.

This bug has been int he game since vanilla.
Often appears with some buggy option ( int he options ofc )
Just a hint where you should keep an eye out.

This consistently happens whenever you open the Options menu and close it during a game, this has happened even in the original.

However, your footage shows that XP doesn’t show even when opening the game from launch and starting a match without opening the Options menu beforehand. This is likely a newly introduced bug.

you still get the XP, only the visual is missing.
In a skirmish match its easy to restore by quicksaving (F9) and instantly quickloading (F10), then the XP should appear again.

1 Like

I’ve done some additional testing and it seems to be related to a graphics card interaction. Looking at the 0:21 mark in the video, you’ll notice that my mouse pointer changes to the standard windows waiting icon (and it doesn’t show in the video, but my task bar flickers on screen at the same time). I have run a few games where this did NOT occur (no indication why it was different) and in those cases XP icons are shown. Lowering graphical options has no effect on this. Monitoring my GPU usage during the match launches, the GPU rails, drops to 0%, rails again, and then resumes normal performance (see below). I have set Windows to use the discrete graphics card for AOE3DE, so there is no reason that the graphics card should not be in use.

A separate issue is when quicksaving and quickloading, after the match the earned xp doesn’t add to the home city, and I’m a sucker for unlocking home city stuff.