Editor - ran editor once, now game is bugged

Game Version: AOE2 DE

Platform: Steam
Operating System: Windows 10

Ran editor for the first time since playing the game for the last 4 weeks, without issue. Since running editor today, my game has been completely bugged. When I run a match I am super zoomed in and the typical game controls like moving through the map by bringing my mouse to the edge, or clicking and directing units, no longer works. I’ve tried reinstalling the game, restarting my computer, and resetting graphics in options, etc. No luck. Have you heard of an editor bug like this?

Reproduction Steps:
Here’s how to reproduce the problem: Run editor.

  1. Run Editor


Try to delete “C:\Users\{username}\Games\Age of Empires 2 DE\{userId}\profile” folder

Thanks for your input @Yorok0. Tried that when I read your message. It did not solve the problem.

i have also validated my game files through steam’s library

I was able to resolve this issue. After resetting all game settings under the tabs “interface, graphics, audio, and game” the game mechanics returned. I was also able to set the game resolution to what I am used to. Thanks to all that helped.

1 Like