Event Challenges not completing

Looks like a new batch of event challenges showed up today.
I noticed that I could do basically all of them in 1 game so that’s what I did. But it only awarded 3 out of 5.

“25th anniversary”
Defeat 25 units only with cavalry :white_check_mark:

This worked correctly.

“Up-rezzed Villager”
Win a multiplayer or skirmish match without losing more than 5 villagers :x:

I lost 0 villagers but this did not complete. Does it only count 1-5 or something?

“Rock Paper Scissors”
Win a multiplayer or skirmish match in which you don’t produce any siege or naval units :white_check_mark:

This completed. I only built villagers, sofa, and my starting scout.

“All Four It”
Research at least 4 technologies before reaching age IV in a match :white_check_mark:


“Victory: Malians”
Win a Skirmish or Multiplayer match as the Malians :x:

I played the match as Malians lol, why did this one not complete? It was a 4v4 quickmatch vs AI…


Did you using tuning pack or mod map in playing, like royal rumble that is part of event too?

That/those may affect some events?

Nope, is that even possible in quickmatch? Idk I don’t use mods.

Same here - I played 3v3 vs AI and it did not count - then I tried regular 4v4 and still didn’t get it. Funny thing is that Ottoman win challenge worked just fine.


Ok, I’ve just tried it once again and this time it worked in a skirmish vs AI.

I figured it would. “Up-rezzed Villager” probably will work in skirmish too. But then it’s strange that “Rock Paper Scissors” worked correctly in multiplayer.

I have the same issue. Tried every possible play style and I still get nothing. I still can’t even complete the 16 elephants on a transport challenge from the first batch of challenges.

Hi all! I can’t complete the “Paris Burning :lock: Destroy 5 buildings with a French Warship” challenge either.
:trophy: Unlocks a profile portrait of Elizabet Ramsey.“. I tried to go through it in the following ways: 1. Build the best French ships and or destroy everything” 2. Build Fireships and destroy all the berths with them. 3. He built ordinary warships with arrows and ballista and destroyed everything on the coast. 4. One ship destroyed more than 5 buildings in a row. None of these methods helped. Played in the mode against AI and on the network game. Didn’t use mods. Administration help us already. I spent 4 days doing it. After 1 day, the event “Celebration of 25 years of the game” will end.

Ships have classes now, it’s not explained anywhere so it’s kind of confusing. Everyone has an arrow class, springald class, incendiary, and warship class. For French, warship is named “Carrack”. Try making only Carrack, destroy 5 buildings, then surrender the match. You don’t have to win to get it.

1 Like

Also, Landmark doesn’t count as 0 hp land mark still not consider to be destroyed, or it doesn’t consider building.

I tried this event destroy 1 landmark + 4 other building and didn’t get it.

1 Like

Same for “It’s All Good”. I’ve played a Skirmish match with these settings:

  • Map: Lipany, Big
  • Players, team 1: myself (Malians), Intermediate AI (Ottomans)
  • Players, team 2: Intermediate AI (Malians), Intermediate AI (Ottomans)

I never repaired any building, but the event challenge did not show “Complete” mark.

Maybe game count friendly AI repair to be failed too.

I played 1v1 and never give enemy chance to repair and get this event.

Hey, all! Sorry I missed this one.

Definitely the first thing to check!

@Heftydogg @Pidzi333 it’s just “Up-rezzed Villager” that won’t complete?

@NilFable just “Paris Burning” won’t finish? Others seem to work fine?

@AceCard32543944 just “It’s All Good” won’t finish? Others work fine?

There’s a bug here we’re looking into.

I have managed to complete them all now. Malian Victory only completed in a 1v1 skirmish. Up-rezzed villager completed randomly one game.

Glad to hear it @Heftydogg!

For anyone else experiencing this, please contact support with your warnings.log file. The team is investigating why these aren’t completing as intended. Thanks!

Small updates:

  • I’ve started the application today, and the “Completed” mark appeared on “It’s All Good” tile, but I’ve completed it during the previous application run. Perhaps the completion status is updated on program exit?
  • I’ve completed now the “Rock paper scissors” challenge without problems: won and marked as completed within the same session, without restarting application.
1 Like