Event challenges not registering as complete

:arrow_forward: GAME INFORMATION

  • BUILD #: 100.12.9476.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Just like in AoE 2 DE, the only challenge that actually works is the “Sign into Xbox Live” one; none of the others register as complete

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Sign into Xbox Live
  2. Check your event
  3. Watch as the first one gets completed
  4. Come back the next day
  5. Play a skirmish game as the Inca
  6. Watch as nothing happens

:arrow_forward: EXPECTED RESULT

You should unlock the awesome Armored Llama profile pic

:arrow_forward: ACTUAL RESULT

Instead, the challenge system is just as deficient as AoE 2 DE’s


Same for me, only that not even the sign-in “challenge” get’s accepted. I signed out and in again 2 times - didn’t change anything, sadly.

There are few enough llamas in the world as is.

EDIT: Tried it again on a whim, and it worked. So maybe just keep trying.

Hey there friends! I want to confirm that you are hitting the Start buttons for the events to kick them off? I actually ran into the same issue you were describing when testing it myself, but was able to complete each day after clicking “Start” and playing through the round.

Let me know if that works or if they continue giving you trouble!