Failed Publishing Mod - Error Mod failed to publish

I am no longer able to publish mods. I get this very helpful error:

I’ve also tried the website, and that does not work either.
I’ve tried taking a mod I already have published, copying it, giving it a new name and deleting the info file, but that still doesn’t publish, even though the files must be correct, since I’ve published them in the past.

I can still update existing mods.

Any help?

1 Like

I have a new error now

EDIT: I am now able to to publish mods again. They just take a very long time to upload.

1 Like

Good day. I have the same problem. I have a large mod that I aim to upload , I have split the mod in two parts , to allow each part to be within the 500mb max upload size. But even though the part 1 is 430mb, it produces the same error when I attempt to upload.

Have you found a soulution as of yet?

Today I got the same problem. I failed to publish my AI mod.
I got the same Error: Unknown.

Same Problem here. My mod is made out of 2 files: 1 scenario and one smx file. The total size is 0.4MB.


@DodoNotDoDo I am facing the same problem. I have tried publishing via chrome and explorer but it gave me error “mod failed to publish” , also tried via mod manager but same problem. please check my recent upload logs.

Should be fixed now.

1 Like

it didn’t upload also no error message only the red box?

PS: upload worked by ingame mod manager but am getting the same no message red box error when i try to add more images via website.

Now it gives “Error submitting mod! Please verify your data and try again.” when am just trying to add 4 more images.

Editing the description gives red box error.

It looks like there was a temporary issue further down the publishing pipeline. About 30 minutes after yours failed, someone else’s went through and others since then have succeeded. Please try again and if it still fails we’ll have to look at if it’s something specific with your mod.