"Favorite civ" in multiplayer profile always resetting

Game Version:

  • Build 101.101.35209.04667120
  • Platform : Steam


Whenever I close the game, my favorite civ in my profile always get reset, whether the games I played previously were ranked or not, and even though the game keeps track of my number of games and wins. I can also unlock the unique unit profile icons just fine.

Here is my profile after winning a co-op gamevs AI as Persian

But the next time I boot up the game…
After that I played a ranked game as Berber
And then I close and restart
Then, I did 2 ranked games in a row, still as Berbers
And after the usual restart

This bug keeps happening to me since the profile section was updated to no longer include the civs played in Single player.

Reproduction Steps:

  1. Win matches in multiplayer (both ranked and unranked)
  2. Go to the profile and note which civ is “the favorite civ”
  3. Close, then launch the game again
  4. Check whether the civ name is still here or reset

Same here. Just another issue this game has that will take a month or longer to fix. Instead, they have more important things to do like add profanity filters because that takes priority over actual game play. Game crashes are still prevalent in matches, villager stuck working in woodlines, Trebs packing up all of a sudden when you’re attacking a building, and melee units pathing and not attacking properly while engaged with the enemy to name a few. But hey… at least little Johnny wont have to see the F word while he plays multiplayer.

This game is an unfinished product. As far as I’m concerned every time they run a new patch it seems to get worse. And one of my biggest complaints is having to see the intro video every time I login to the game. Please for the love of God put a feature in the game where I can skip the intro video and it takes me right to the main menu. The stupid thing lags all the time especially when I click to skip it. Supposedly you guys fixed it, but that never happened.

I’m pretty happy with the path finding right now and the performance that was improved tremendously (the game now runs just fine on my 4 go RAM laptop) To skip the intro video, if you’re on Steam, right click on the game’s name in your library, go in properties, and in the general tab click on “set launch options”, then type SKIPINTRO, and you should never see it again.

Thanks for that tip with the skip intro. It worked actually. On my system that video lagged so bad most of the time when i clicked to skip it.

1 Like

Always happy to help : )