File missing in subscribed mod

It worked once I removed all the chinese characters in mod description, so I guess the system is racist Kappa

So I published a custom scenario through the in-game system and shared it to my friends, they told me that for some reason they just coudlnt subscribe to it. So I tried to subscribe to my own mod and also failed.

I then tried to zip it and publish through the aoe website, still no luck. Turned out the folder with the mod title did came to my subscribed mod directory, yet the folder contained nothing other than the json file.

I managed to publish other random stuff (eg. rms / cs / ui mod) afterwards, so any chance theres something wrong with my custom scenario?

PS. Files and folders are all in english, mod description and triggers in the scenario contain Chinese characters tho.

1 Like

does any of the players have their window account with chinese or special characters? theres currently an issue going on with mod fail to subscribe because of it. the current workaround is to create new window account at log on with only english characters.

1 Like

It sounds like you might be doing what I did wrong when I published my first mod. I could be wrong about this, but what files are you zipping. If you are zipping the full mod folder, that’s your problem. Make sure you zip the directories just inside your mod, should look something like this (although you might not have all the following directories):

Afaik no, my own account has no chinese character in it either.

Nope, I just zippped the files inside the mod directory when I tried to do it “manually”.