Found Bug; attackmove+clicking on minimap wont do anything

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Steam Lastest today
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

doing atack move + click on minimap wont work, unless you move the mouse first. its really anoyng cause I have self automated this action. Select some units to move on a “attack move” stance, point to the miniap and hotjey “attack move” then click. Nothing happens, I just found out that I wont do anything unless I move the mouse. So I need to hotkey, move the mouse, then click where I want untis to go.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

Happens on ranked and Single Player games

:arrow_forward: REPRODUCTION STEPS

  1. Select military unit(s)
  2. point on a direction on the minimap
  3. press “Attack move” hotkey and dont move mouse
  4. keep clicking and nothing will happen.
    if you move the mouse and click the same place it will work

:arrow_forward: EXPECTED RESULT

“Attack move” actually works this way whitout moving the mouse

:arrow_forward: IMAGE

not necesariy

:arrow_forward: GAME FILES (SAVE / RECORDING)

Not necesary

I have similar issue but only about 30% of the time. I find that if u spam click like once or twice more it does work.

1 Like

Different hardware, different results? i’ve tried clicking like for a minute straight forward whit no effect. I bet yo get to move the mouse a little when you spam clicks, or It’s something else related to different computers. otherwise, I don’t get why it works this way.

the fact that only moving the mouse make it work makes me thing that when the hotekey is pushed its waiting for an X,Y mouse input, and there’s no refresh so it forwars null,null or something

1 Like

honestly im not sure but im surprised to hear you clicking a min straight and still not register. I do find it harder to attack move on the minimap but it does work more often than not.

have you try verify game file or reinstall game? It might sound silly that have to reinstall game, but this game has crashed so much that it cause some of game file to corrupt and I started getting lag and other issue, only reinstall fixed it for me.

Found out that it missbehaves only when Attack Move is mappet to “Tab” key, otherwise seems to work fine

1 Like

Thanks for your report! We’re now tracking this issue :slight_smile: