Futuravailableunits.json file isn't moddable

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.61591.0 8647032
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

According to update 58259 patch notes, futuravailableunits.json is now moddable, but that isn’t the case. By creating a resources\_common\dat\ path and placing a futuravailableunits.json file there, the game understands the mod as a datamod, so you can’t “tick” it to turn it on (like all other mods that turn on at game start). I’ve tried placing the file by itself in the mod folder, and all that does is make the game boot me out once I try to load an scenario. If I have it accompanying a dataset, nothing happens and the game loads as if I hadn’t placed/modded futuravailableunits.json there at all.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Mod futuravailableunits.json
  2. Place it in the correct mod path resources\_common\dat\, along with an empires2_x2_p1.dat file
  3. Attempt to start a skirmish game, and notice nothing you’ve modded changed

:arrow_forward: EXPECTED RESULT

The modded futuravailableunits.json file takes precedence over the base game’s one, and displays its contents instead.

:arrow_forward: IMAGE


:arrow_forward: GAME FILES (SAVE / RECORDING)


1 Like

yea they moved the default location where future.json file is located but it also stopped working. I filed the bug report like 2-3 weeks ago but not yet addressed, its still not working as of May’s PUP cause I tested it also… we can only hope

1 Like

Hi @CaseConstant523 !

Thanks for this, we are now tracking this issue ^-^

Thanks for popping this up @thieftdp8498 :hearts: