Game application loads for very long time before intro starts

Probably, tomorrow i’ll test if some other commands work but you need specific game commands.

1 Like

I have had long load time since release of the game. It cannot be just on launch commands as very few use them but still have instant load

1 Like

its the mod causing the slow down. AOE2DE clean game starts fast for me and I tested this just 2 nights ago.

clean game = 10-15 sec start up before intro movie starts.
with my mod = 35-45 sec to load up before intro movie.

the more mod you have the slower it gets, not sure why developer choose to load the mod into memory before game starts. it should only load the mod if we choose to use specific mod to play.

1 Like

What mods are you talking about? Is it like the event mods and graphic mods you can subscribe to?

It feels like when you set the option to skipintro, it’s like it still waits out the length of time for the intro but just doesn’t play the video. I’m kind of okay with that, because it’s not that great of an intro compared to the old one, that and it uses to run really slowly and was hard to skip when it started.

I tested it yesterday again, without mods 1 min. 30 sec. starting time, I also have the same result with mods activated

Situation is getting worse and worse with new builds. In “101.101.37650.0 5061880 Steam” I now need 2 minutes 30 seconds until main menu loads :slightly_frowning_face:
Will I need 10 minutes in the future?

1 Like

without mods, it takes me 15-20 seconds. with my mod, its 40-45 seconds to start before intro kicks in.

Any luck from anyone? My game takes 15-30 minutes to launch. It’s been this way since release.

1 Like

This has to be a record… :trophy:

I disabled all my currently enabled 31 mods to check whether these increase startup time. Didn’t help, still 2 minutes 30 seconds.

disable mod does not help. you need to REMOVE them from local/subscribed folder. even if they are disabled, game still loads all of them before start into memory or some sort. its just this game is too ■■■■ old not sure if any of the devs know how to get a fix around this.

with my mod in my local folder, it takes 30 sec to start, without it only takes 8 sec.

@Schoffrey again, DISABLING will not change anything, only REMOVE them from local folder/subscribed folder.

1 Like

So the game core files load in 8 seconds, while your mod loads in 22 seconds. This is disproportionately large loading time for a mod and so is clearly a problem caused by the game.

Most of my mods are campaigns, which should cause nothing to be loaded until I start them from campaign selection screen. Most of my other mods are applied to the game based on their current state, not state at startup (I know it, because changes to them are applied without needing to restart application). This means, that they should not influence startup time.

It appears, that game is doing something very wrong, so that mods cause disproportionate increase of startup time. Especially knowing, that game manages to load its massive amount of files at startup in seconds for many people. This is a bug and should be fixed.

1 Like

yea mine is data mod. its a lot less file/content to read through so im not sure why it takes longer, or why it would even take longer in the first place. datamod with it’s graphic data should not be loaded whatsoever until we choose and start playing it.

1 Like

when i open AOE2DE on Steam, game opens like in a min. Can anyone help me for this please?

1 Like

read above and you have your answers

my English not good at all 11 which one is the correct answer?

Answer is that there is no good solution. You might manage to decrease your startup time by unsubscribing from mods, but that solution is of course not ideal…

i can unsubscribe some mods its ok for me, i’ll just copy those folder somewhere and unsubscribe

Wait I have exactly that issue sometimes (up to 2 mins lol), hope MS fix it :frowning:

1 Like

I documented a workaround in this thread that worked for some of us.