Game application loads for very long time before intro starts

its the mod causing the slow down. AOE2DE clean game starts fast for me and I tested this just 2 nights ago.

clean game = 10-15 sec start up before intro movie starts.
with my mod = 35-45 sec to load up before intro movie.

the more mod you have the slower it gets, not sure why developer choose to load the mod into memory before game starts. it should only load the mod if we choose to use specific mod to play.

1 Like

What mods are you talking about? Is it like the event mods and graphic mods you can subscribe to?

It feels like when you set the option to skipintro, it’s like it still waits out the length of time for the intro but just doesn’t play the video. I’m kind of okay with that, because it’s not that great of an intro compared to the old one, that and it uses to run really slowly and was hard to skip when it started.

I tested it yesterday again, without mods 1 min. 30 sec. starting time, I also have the same result with mods activated

Situation is getting worse and worse with new builds. In “101.101.37650.0 5061880 Steam” I now need 2 minutes 30 seconds until main menu loads :slightly_frowning_face:
Will I need 10 minutes in the future?

1 Like

without mods, it takes me 15-20 seconds. with my mod, its 40-45 seconds to start before intro kicks in.

Any luck from anyone? My game takes 15-30 minutes to launch. It’s been this way since release.

1 Like

This has to be a record… :trophy:

I disabled all my currently enabled 31 mods to check whether these increase startup time. Didn’t help, still 2 minutes 30 seconds.

disable mod does not help. you need to REMOVE them from local/subscribed folder. even if they are disabled, game still loads all of them before start into memory or some sort. its just this game is too ■■■■ old not sure if any of the devs know how to get a fix around this.

with my mod in my local folder, it takes 30 sec to start, without it only takes 8 sec.

@Schoffrey again, DISABLING will not change anything, only REMOVE them from local folder/subscribed folder.

1 Like

So the game core files load in 8 seconds, while your mod loads in 22 seconds. This is disproportionately large loading time for a mod and so is clearly a problem caused by the game.

Most of my mods are campaigns, which should cause nothing to be loaded until I start them from campaign selection screen. Most of my other mods are applied to the game based on their current state, not state at startup (I know it, because changes to them are applied without needing to restart application). This means, that they should not influence startup time.

It appears, that game is doing something very wrong, so that mods cause disproportionate increase of startup time. Especially knowing, that game manages to load its massive amount of files at startup in seconds for many people. This is a bug and should be fixed.

1 Like

yea mine is data mod. its a lot less file/content to read through so im not sure why it takes longer, or why it would even take longer in the first place. datamod with it’s graphic data should not be loaded whatsoever until we choose and start playing it.

1 Like

when i open AOE2DE on Steam, game opens like in a min. Can anyone help me for this please?

1 Like

read above and you have your answers

my English not good at all 11 which one is the correct answer?

Answer is that there is no good solution. You might manage to decrease your startup time by unsubscribing from mods, but that solution is of course not ideal…

i can unsubscribe some mods its ok for me, i’ll just copy those folder somewhere and unsubscribe

Wait I have exactly that issue sometimes (up to 2 mins lol), hope MS fix it :frowning:

1 Like

I documented a workaround in this thread that worked for some of us.

I deleted whole temp folder, but it did not change game startup time for me. Thanks for trying to help though and hopefully this helps someone else.

@Yorok0 Yeah, your particular case seems a bit different because the lag happens in between clicking the button in Steam and the splash screen showing up at all. Some of the replies seems to be describing the other issue, so I figured it’s worth mentioning it here.

If this bothers you enough and you are willing to dig around a bit, the process I used to uncover the other bug may give you some insights into what kind of work is going on behind the scenes, thus giving you a shot in finding a workaround.

What I did is use Process Monitor to spy on the game. It is a debugging tool by Microsoft that shows you what Steam or the game is asking the operating system to do – opening/reading/writing files, network requests, etc.

First, launch Steam and get it to a “steady state” – let it finish checking for updates, close any welcome screens and navigate to the Age Of Empires II page where you can click the start button (but don’t click it yet).

Then download the tool from Microsoft, extract the zip file, right click and run it as administrator.

You should see a screen like this:

At any given moment, there are a lot of things going on in the operating system, so it will be extremely noisy to list every single event. Therefore, the tool gives you an opportunity to narrow down the events you may be interested in.

It comes with a bunch of default filters that excludes things you likely don’t care about, but it’s still going to be quite noisy. What we want to do is to narrowly focus on only things Steam or AOE is doing. As shown in the screenshot, the filters you want to add are:

  • Image Path is C:\Program Files (x86)\Steam\Steam.exe then Include
  • Image Path is C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\AoE2DE_s.exe then Include

Here, “Image Path” means the location of the .exe files you are interested in. You may have to adjust the paths based on where your game is installed.

Press Ok and Process Monitor will start listening for and enumerate events matching your filters. Anything you see now before you start launching the game is probably “normal” Steam events and can be ignored for our purposes. Take a mental note of any events you see so you know to ignore them later (there may not be any – when I tried it on my computer, there were none), then press the “Clear” button (Ctrl + X) to remove them from view. You may also want to turn on Autoscroll (Ctrl + A).

Now press the “Play” button in Steam and observe what happens. It is going to be a firehose and most of the events are probably uninteresting. What you want to look for anything that “stands out” which may give you some clues on what it is spending its time on.

Here are a few rules of thumb:

  • Reading from the windows registry (RegOpenKey, RegQueryKey, RegCloseKey, etc) is probably uninteresting, it’s pretty normal and unlikely to be slow. You can make a filter to ignore them if you want.
  • It’s going to load a lot of .dll files (anything with a .dll in the Path column), but that is also pretty normal and probably not your problem, unless you observe that it’s spending a lot of time on loading a particular .dll file. You can also make a filter for it if you want.

You are specifically interested in getting some insight into what it is doing during the time where it’s “stuck”.

If you are lucky there will be a big gap of time where there are no events, which probably means it is waiting for the last event to finish, in which case whatever it is, is likely the problem. An alternative explanation for this is that it is spending time doing non-operating system level stuff, which would be much harder to figure out. It is also possible that it is doing the work in a differently named .exe so it escaped our filters.

Another possible (and more likely) scenario is that during the time it is stuck, it’s actively doing some work and causing a ton of events. This is what happened in my case, and led me to discover it’s slow because it’s trying to go through all the files in %TEMP%.

If you are able to do this, then you can compile a sample of the events, and I can help look into it. Those of us who don’t have the same problem you described can also run the same experiment and tell you what events are found and to be expected in a “healthy” setup, so you can cross-reference them with your list to narrow down the possible suspects.

2 Likes