Game capped to 60 frames per second, even outside menus

Game Version:

  • Build: 101.101.37650.05061880
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Sogomn

Issue:

The game is capped at 60 frames per second, regardless of the vsync setting.
This happens outside of the menus aswell.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Monitor the game’s FPS
  2. Join a game
  3. Observe framerate with both vsync on and off
1 Like

Yes. I was about to post the same issue here. I used to have like 200 FPS and since the new patch came out my ingame FPS is locked to max 60. (does not matter if it is SP or MP).

V-sync is disabled

" * Limited the framerate of out-of-game menus to 60 FPS."

  • Maybe could happend that you by mistake capped out the maximum FPS to gameplay as well ? @GMEvangelos

Thanks for the report! I’ve passed this along to the team so they can take a look. =)

After the update, someone else had lost the fps ?

1 Like

I think most people have, but noone is really noticing it or complaining I guess…

For what I know - Game right now acts like you have V- sync checked on (even if you dont have) so it slows down to your Monitor refresh rate (in our case 60Hz = 60FPS)… Most people have no problem with 60 FPS i guess, but this means also another problem (at least for me).

When there is a big battle going on - My PC tend to go below 60 FPS, but with forced v-sync he cannot. And when this happens i still got my 60 FPS but I experience Stutter like this:


timestamp: 1:32 is most visible

At least thats my theory, because i NEVER HAD this kind of unit Stutter before
@SkilledYapper10

Same thing happened to me right after the 37650 update.
I play in 4K resolution with UHD graphics but I tried disabling UHD option issue remains.

1 Like

It looks like vsync is enabled by default even if we don’t select it. I have a friend with 120hz monitor and he is capped also but arround 100 to 120 fps.

1 Like

Good day, friends! After escalating this report to the team, I have a few notes to share:

It seems that this is the intended design, as it is part of a fix that prevents the game from pushing the graphics card on some users’ systems too hard. The short answer:

By capping the number of frames to the display’s refresh rate, we no longer waste GPU cycles which could be used by other applications, processing power, and (on the whole) decrease the battery power (and/or energy) that is consumed by playing the game.

Utilizing V-sync should continue to improve the frame rate for users running below 60 FPS, but un-checking the option now caps the refresh rate to what your monitor can handle.

I hope that answers the questions, and encourage any other issues to be split off so we can look at them individually!

Thanks, again, for the report! =)

1 Like

I think that is a terrible decision. Especially since input seems to be tied to the framerate. This increases the number unintentionally placed gather points significantly. It even takes two to three tries to open the chat sometimes (not necessarily at 60 FPS but when a player is lagging).
I think anyone who disables vsync is aware that the framerate is uncapped, unless specified otherwise. This is also kinda the point of playing without vsync - you trade reduced frame delay (and in this case also input delay) for screen tearing.

1 Like

Alright so I got a 240Hz monitor. The game is still capped at 60 frames per second. Even if it’s supposedly being capped at the monitor refresh rate, it’s not working as intended.

1 Like

Hi all,
I used to play around 200-250 fps at low settings (mostly because personal preference) but right now my fps is locked to 60 fps and doesn’t change with ultra graphic settings, and it makes some post Imperial match feels awkward due to fps drops.

Please let me know if this is happening to you too or you have any solution to my problem.

No that does not answer the questions at all unfortunatly.

Could you please remove this ?

If a user want to cap the number of frames to the display’s refresh rate, he can enable the vsync option, that is the point of this option.

The box could be already selected by default, but if we un select if we should be able to go back to 200+ FPS as before the patch.

Thanks

3 Likes

Hello. Sorry to say, but I really dislike this option… it is such a microsoft-type of move, similar to windows 10 updates - forced to do it.
As others have said, make it a CHOICE, an option for people to choose. You can set the default vsync to on, you can give a warning for gpu overheating, overusing when someone tries to disable, but for godsake let us CHOSE!
I used to play on my laptop with 100-120fps and is ok. At work, i played a bit on the desktop and was so amazed at the responsiveness with 250fps. And now - 60fps!!! I never liked to play a game with less than 90fps unless i had no other choice…
So in my opinion - terrible decision.please reconsider!

Blockquote
By capping the number of frames to the display’s refresh rate, we no longer waste GPU cycles which could be used by other applications, processing power, and (on the whole) decrease the battery power (and/or energy) that is consumed by playing the game.

I actually close most of the baground processes/applications to play age of empires… age of empires 2 de on a laptop battery IMO should not be played… reducing energy consumption by not letting us have high fps is just silly…
I love how much better in terms of response is Aoe2de compared to HD. It’s the reason I moved to it, even though it doesn’t support all the mods I like. However, it’s far from VOOBLY’s responsiveness. And with this 60fps cap, you go further away… It’s really a bad choice with a silly reason. Trying to think what is better for us, forgetting that you can just ask and let people chose what suits them best.

People who can’t put VSYNC on to achieve all the reasons you said - might be bad from me, but I think they deserve it. How lazy are humans, to have to treat them like an incapable kid and is this actually helping or making people even lazier?

Apparently this is marked as “solved” issue here: https://www.ageofempires.com/support/aoe2/aoe2-issues/

Forcing v-sync brings a very noticeable input lag because there is no guarantee that the 60 fps that you force the game to be capped will be synchronized with the monitor refresh rate.

If you don’t notice it but other people do, at least please let us control whether we want this activated or not.

Honestly what other games have you seen that forces vsync on even if you disable it in the option ?

This can be solved by adding a framerate cap option separate from v-sync as many other games do it already. To bypass the issue right now, maybe you can force v-sync off in the graphics card drivers? I need to check this first when I’ll have the time.

ive been at 120fps ever since i installed the game.

Good idea, I’m also trying to by pass this limitation. I was wondering if there could be any config files of the game that could be modify to work around this. For example I’ve seen some people moving around the resources panel, or the minimap.

Most likely you are using a 120hz monitor and you had vsync on the all time so on your case you are not really impacted.

my vsync is off btw. but i do have 120hz monitor