Game Closes After Launch Screen

Hello guys, I can not play the game, this is very bad because I bought it to relax and precisely while looking for “solutions” what I do is stress more, to charge in Microsoft are very efficient and I like that, but to solve a problem They are not as fast. I just bought a laptop and I just want to be able to play some hours on Sundays to relax my mind, but no, now I’m looking for solutions everywhere to see how to fix something I do not know what it is, the game is not starts, only shows the initial image and closes, I have not been able to play for a second, I have downloaded and installed several times and nothing at all, it does not work, this seems really an abuse, have you managed to solve your problems? Because I have not yet achieved it, I think it’s a great joke … if anyone has a solution, it would be great if he could help me, I want to fix this error and enjoy the game quietly, it’s unfair that one pays for something, and instead to recover a reward, what you receive is a grievance … At least someone has returned their money …? Because that would be a quick solution.

If you want help you need to show your specs of the laptop. What new laptop did you buy?
Brand, model, CPU and GPU specs please.

Hello, thanks for answering, of course … I have a Lenovo Ideapad 320-15AST. I do not know much about computing now, I will give you the data that you tell me in the section “about the system”:

Processor: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C + 3G 3.00 Ghz

RAM INSTALLED: 8 GB (7.39 usable)

System based on 64 bits.

More than 850 GB on the hard drive, with a 1 TB disk

Windows 10, version 1803

What else do you need to know? I do not know if this laptop has a video card, where can I see that? I think that in case you have it, it would be a radeon, I think here I have the information:

I’m really sorry for you but the AMD A9 R5 series laptop GPU’s are definitely not supported.
These are far below minimum specifications.

1 Like

Hello i need help. I have same problem in me PC .
i5 2500k
8gb ram
gtx 1060
me game canot start i see only first screan 3sec and game crash.

The problem is most likely caused by your CPU as AOE DE needs at least a 3rd generation Intel CPU.

Your i5 2500k is 2nd gen. Also your CPU does not support PCI Express 3.0, so your GTX 1060 falls back to 2.0 specifications which will give some performance hit too.

As your i5 has 4 dedicated cores it reach specifications but maybe the game doesn’t detect your GTX 1060 correctly and then fails on detecting the HD3000 integrated graphics of the i5 2500k.

Only one more thing to check, but that problem was solved already long time ago. Download a free game in the Microsoft Store, put it on hold (pause download) and then start the game. I don’t think this will help with your problem though.

You need a new mainboard, memory, CPU and some better advice from a hardware expert. :wink:

i play on my pc all new GAMES and this ■■■■ have a problem.? hahaha time to refounding.

I don’t think it’s hardware problem, I already tested on a 2nd gen Intel CPU and it worked.

I would also advise to try this :

1 Like

A quadcore socket 775 with a decent graphics card can run the game. I would check your account settings. Sign in Xbox with the same name in MS Store and see if that helps. Make sure you use the account that purchased the game.

nothing helps with it.