Game Crash + Disappearing / Glitching Monks

Game Version:

  • Build (101.101.33315.0)
  • Platform (Steam)


1.) The game crashed in the middle of a multiplayer match. The game just shut down completely and closed out. My buddy tried to save the game and reinvite me but my team had already been replaced w/ an AI so it didn’t work.

2.) There was a glitch when I upgraded to the Castle Age where certain sprites / buildings / units disappeared from my screen. For me it was the Stable and my Monks. They existed, but I could not see them. Also, if I tried to build a new Stable the game would show “where do you want to place” icon but would not show the transparent building graphic nor would it let me actually pick a location to build. My buddy and I had to save the game and restart it for my units to show up again.

I got exactly the same issue. Multiplayer match. Invisible monks, but my allies can see them. Invisible stables: no transparent image when placing, when building in progress a construction image appears but when building complete, the stables become invisible again. And after sоme time - game crashes.

Build 101.101.34223.0, Steam

I wonder, maybe the source of the problem is Enhanced Graphics Pack? SWT83, do you have it installed?
Will try without Enhanced Graphics Pack.

No, I’m not using any mods at all.