Game crashed to desktop

I just had a crash with the changed settings. So I was just lucky yesterday. I’ll attach the main-specs below, as well as the full DxDiag-report with all the details.
DxDiag.txt (122.4 KB)

         Operating System: Windows 10 Pro 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
                Processor: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz (4 CPUs), ~2.7GHz
                   Memory: 16384MB RAM
                Page File: 10772MB used, 8401MB available
          DirectX Version: DirectX 12
Microsoft Graphics Hybrid: Supported
 DirectX Database Version: 1.1.2
           DxDiag Version: 10.00.18362.0387 64bit Unicode

           Card name: Intel(R) HD Graphics 620
      Driver Version:

           Card name: NVIDIA GeForce GTX 950M
      Driver Version:
1 Like

and mine:

From what we’ve got now, the only common denominator is we both use Nvidia cards from 600-700 generation. It could be graphic’s problem. How about giving this a bit of audacity by starting a new thread? I have a feeling it’s going to be just ignored down here in the comments

I’m too new a user to qualify starting a new thread, that’s why I’m asking you.

Have a good day!

i opened another thread, but i got the same problem.

I added some clips from stream where its possible to see how the game goes freeze and then close for no reason, no log, no exception, nothing to track, just the game close.

its not working for a 1060 user (me) either, so I reckon it’s not related to that.

Just to check, have you all updated your graphic card drivers?

@JexBall Yes, at least I did. Just begin looking for a memory leak in AoE2:DE, please.

I have 16 GB physical RAM, set swap to 24 GB RAM, and it still crashes with not enough memory messages showing up.

Yes, I did. I’m using the latest 441.41 released on 2019-11-29

can you have a look at the event log in Event Viewer (search in Windows start) > Windows logs > Application?

My problem is 0xc0000005 at offset 0x0000000000a276f1. See if it’s the same problem

Yes i got the same exception in my visor. I add some scr.

I’ve had the same exception as well after a crash

I did not have time to look more into memory usage, but I noticed two things in the resource monitor.

  1. The memory usage of AoE is fluctuating a lot (means: a lot of small memory requests to the system)
  2. A secondary process (svchost.exe LocalServiceNoNetwork -p) that uses ~4GiB of memory for a few seconds. Latter will fill up the swap if it is managed by the system and not enforced to a larger size.
    (Note that there is memory on stand-by that is not shown as used by the task-manager, but neither is free)

With the post of TranceInvasion my hypothesis is, that one of the many memory-allocations is rejected by the kernel; maybe due to both memory and swap being nearly full. If the memory is used anyway we get the segfault-crash. I could not test this fully yet, though.

1 Like

wow. this is so detailed on your part as a user. while I was just content to wait for the dev team :facepalm:

@SkilfulGlint214 have a look?

same issue for me…when i purchased the game it crashed a lot…then i closed all other programms and set my swap memory to 12 - 20 gb…now it’s more consistent but crashes every maybe 2h…
platform steam
latest build
8gb physical memory
same error log

Same here, it crashes ALWAYS after about 5-10m when playing multiplayer. Seems to be more stable when playing against AI only.
Fresh windows 10, all patches installed, AV disabled etc.
What is interesting is that I also have AOE I DE, it also crashes.
Interestingly there was time where AOE I DE was not crashing, then installed some windows updates and after that it started crashing again.
This happens across both PCs I have, which we are trying to use for local multiplayer.
Tried everything, no other games are crashing, just all AOE.

Ryzen 3600, 16GB RAM, SSD 1TB, AMD 390X 8GB.

This game is getting really frustrating and sincerely it is pissing me off. Why can’t any of the developers fix this fcking issue already?? It’s been nearly a month ever since the release and still the game continues to crash after several updates. God the fcking d*mmit, fix this problem already!!

I need to save every 20 seconds because the game close and the autosave is not from the game I’m playing!! I hope they fix this soon because I am playing the 2013 game because I can’t play the new one like that, I loose all information from my actual game

My brother still has this issue everyday, while my pc runs it smoothly. With his pagefile set at 20 gb it seems to randomly crash every hour orso, before it crashed every 5 minutes. Upgrading ram from 12 gb to 16 gb didnt fix the problem. Some of the systems mentioned above are way better than my brothers so buying a better pc is too risky since the problem seems to be random.

I’m also having this problem with my “meager” 16gb RAM and 970m…