Game crashes after about 1 hour in the "Siege of Acre" campaign scenario

The game crashed after a few minutes when I tried to load a save. The first time it was about 42:08, the second time - about 1 hour. Every time I tried to load a save, the game would load and I would play, but the game would close at the same time. I don’t know what a reason, I’ve tried various things from boot time to crash but it didn’t work.
It’s horrible, I’ve lost 2 hours and can’t load a save. I was hoping it was a one time thing, but no, the problem is regular.

1 Like

My Game freezes on this mission as well, seems like gpu driver crash?! I have no problem with Multiplayer or any of the other campaigne missions so far. The difference is, that my game crashes at about two seconds into this mission. this is reproducable and i can not finish (or in this manner, even start) the mission.

update:
nevermind, my issue was not with the game but with the amd (linux mesa) driver. lowering the graphic settings in this case worked.