Game crashes after loading into any game (single player, multiplayer, campagin, etc)

  • Build (update 34055)
  • Platform (Steam)


After the latest patch I cannot join any game, multiplayed, campaign, single player, etc…
After the loading screen (where the AOE2DE Civs are shown etc), the game crashes and I get an error message. I’m attaching the error details I get, I was not getting this errors before the latest patch…

Reproduction Steps:

Starting any single game

Problem signature:
Problem Event Name: APPCRASH
Application Name: AoE2DE_s.exe
Application Version: 101.101.34055.0
Application Timestamp: 5df6f454
Fault Module Name: d3d11.dll
Fault Module Version: 6.2.9200.16570
Fault Module Timestamp: 5153b56b
Exception Code: c000041d
Exception Offset: 00000000000f2d72


Exactly the same error. Exactly the same issue.

Absolute no problems before the update. :frowning:


Same here, except I don’t get any error messages. The game just crashes.
I realized I can normally start editing a scenario, but it will crash if i select any unit or even a tree. So the game is probably crashing when trying to initialize these objects (villagers, gaia units, trees, etc.)
Also, are you guys using Windows 7? I’ve seen other Windows 7 users complaining about this issue after today’s patch.

1 Like

I am yes. And i sense the following straight away - “you dont meet the requirements”. I was playing so nicely since launch with no issues whatsoever. Why should some fancy snowballs wreck this? And there is no way i can turn them off…

Seriously frustrated. I’ve updated all possible things, even reinstalled directx…


Confirmed here as well.
Scenario editor works fine. All terrain i’ve tested is working. As soon as i try to place a unit - it crashes.

1 Like

Why should some fancy snowballs wreck this? And there is no way i can turn them off…

Well, I won’t say much about it because I literally got muted by a MS mod earlier this afternoon for “theorycrafting” lmao. All I know is I learned the lesson not to give any more money for someone who is also trying to sell me a new OS. Anyway I’ll just wait for the guys on Voobly to solve everything and save this game, as always.

Exactly the same problem here since installing the latest patch. Was working fine before but now can’t play at all…

same for me…
i start any game or the benchmark test and it crashes ;(

@FeloniousBard92 , @LACyMe
What OS are you guys using?

I have the same issue - the game just crashes when trying to enter a game (single player, multi player). It worked fine before this update. I am running on windows 7

Computer specs:

1 Like

Same error here after update I can not play, W7.

i’m running windows 7 professional

I also have this bug, running Windows 10. Nice stability release…

1 Like

You guys running win7 - you realise that windows 10 64bit is the minimum supported spec, right?

d3d…are you guys running integrated graphics?

1 Like

There is no justification, just after the patch problems happen, since I bought played normally on W7.

Unless the requirements also changed after upgrade.


Windows 7 has exactly 26 days left to live. If you do not upgrade, you run the risks of not being on a supported operating system, including not receiving security patches.

Anyway, if people start posting their hardware specs (cpu, gpu and ram) and windows version (including architecture) then it might be possible to start seeing a correlation.

1 Like

I love this justification. I’m just hoping for Microsoft to officially use it soon, suggesting AoE 2 players to upgrade to Windows 10 to continue playing. That would make their ethics much clearer for everyone. I wouldn’t be surprised a bit if the next patch turns out to be incompatible with machines without the latest Excel or whatever bs they can come up with.

The operating system should not be used as input into whether or not a user can or can’t play the game. This game is basically an enhancement of a game that was able to run on Win95 & ME Operating Systems - no reason why it shouldn’t run on Win7. Also, everyone who posted had no issues prior to this update.

Here the system requirements on the steam page

Well am using Windows 10 and i can’t even start the game after the update