Game crashes at startup

UPDATE: the issue appears to have been fixed with a Windows 10 update to version 20H2. Woohoo!

:arrow_forward: GAME INFORMATION

  • BUILD #: 4##### (unknown, can’t get into the game)
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

When I try to launch AOE2:DE from Steam, the game crashes to desktop 100% of the time. The game gets past the splash screen and about a second into the intro movie before abruptly returning to the desktop without any notice or error message.

If I try to launch the AoE2DE_s.exe directly, I immediately get an blank error popup, see attached below. The splash screen will appear in the background but will return to the desktop after a couple of seconds, or will rarely make it to the intro movie before crashing a second in similar to launching from Steam. Again, no other notice or error message afterwards.

As far as I am aware, all of the steps in the guide in the support article " After installing an update, the game crashes shortly after launch" have been followed and my machine is up to date. I have done numerous file integrity scans via Steam as well as complete reinstalls of the game.

This all only started happening following the last patch on November 19. I do not have any antivirus running other than Windows’ built-in stuff.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / can’t play the game

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start the game.

:arrow_forward: GAME FILES

:arrow_forward: IMAGE & ATTACHMENTS

The blank error popup when launching the game from AoE2DE_s.exe directly:


EDIT, as I SOLVED it: If you have Nvidia drivers, or Nvidia GeForce Experience:

  1. Go to the panel, and install last update. For some reason, don’t know why, it was uninstalled.
  2. Restart computer as the panel tells you
  3. Start steam again, & aoe and it worked for me

Best regards, hope this helps!

Same happens to me, since this morning.
Yesterday (about 18 hours ago) I played without any problems. Tried to start the game now, and a white error window appears with no text, and it doesn’t let me launch the game.

Tried to verify the integrity of files, nothing happened.
I have same blank error popup as OP.