Game Fails to Launch after March Update

Game Version:

  • Build: (March 21)
  • Platform: (Steam)
  • Operating System: (Windows 10)


Game fails to launch from Steam after the most recent update.

I have tried the following:
-Verifying the game files
-Disabling Windows Defender
-Restarting my PC
-Restarting Steam

by removing my entire mods folder (Users\me\Games\Age of Empires 2 DE\userID\mods) the game did launch. Buuuut, it then crashes in the main menu (I assume once the mods have re-downloaded).

Seems the fix might be to unsubscribe from the relevant mods on the website
Not sure yet which mod is causing issues
I have these subscribed:


I have the same issue with the same platform and OS. Have you installed the lastest Windows update? I did it and I’m wondering if this has something to do with this bug.

Seems it is some mods that were broken. Still trying to figure out which

1 Like

I’ve read something about small trees, but not sure.

I’ve erased the file mod-status.json and it launched. Try doing this and disabling the mods from the mods menu.

Edit: It crashed anyways when it starts downloading the mods again. :frowning:
Edit2: I opened that file and erased all the mods except the spring mod and it’s running! Maybe you can try this and play with no mods until they fix this.

After removing the mods folder twice, I was able to successfully launch the game, and now I copied all the mods back and everything seems to work. I’m using the new auto-generated mod-status.json file instead of the old one.

1 Like

I had the same problem and solved it by disableling the mod The Age of Kings Main Menu in the file mod_status.json .
Not sure if other mods are also incompatible with the last update.

Thanks guys so much. I had same problem. Deleting all mods in mods folder helped and now I can run the game !

Another solution seems to be to start the game while offline, as this prevents mods from downloading, and then to disable them as necessary.

Please edit this file :
C:\Users\UserName\Games\Age of Empires 2 DE\UserID\mods\mod-status.json, and set the value to false for the field “Enabled” of the AOK Main Menu mod.

{“CheckSum”:“0”,“Enabled”:false,“LastUpdate”:“1583427499733”,“Path”:“subscribed//3738_The Age of Kings Main Menu”,“Priority”:3,“PublishID”:0,“Title”:“The Age of Kings Main Menu”,“WorkshopID”:3738}

I’m sorry to have made you difficult, I will update my mod soon.

1 Like

It’s not your fault. Thanks for putting in the work for this amazing menu mod! :slight_smile: