Game freezes following new update

Yes, you need to wait for a hotfix and hope they will sort it out soon. But, they have a small team, so we don’t know how much time it will take. It should be done soon, at least that is what professional company should do.

I tried playing today for this first time since the new DLC became available (I did not purchase the DLC). It froze on me multiple times, each time while going up to Feudal. Once in a 1v1 ranked (no DLC civs or new maps), twice in a 2v2 non-ranked multiplayer (2 humans versus 2 AI, 1 of us a DLC civ on a new map), and once on a 1v1 against AI with no DLC civs or new maps.

My friend I was playing with has a newer PC from about a year or so ago, and it hasn’t crashed for him yet. Mine was built in 2014 (and has a graphics card from 2011 lol).

Cant play anymore after the last update. Game crashes early in the match (100%) in any mode. Reinstalling windows and all the known fixes that are in the forums dont help. Seems like issue bound to specific hardware. FeelsBadMan I just bought a new keyboard to play the game.


Same Problem here :frowning:

Same here, I haven’t been able to play a single game without crashing since the new DLC came out, and I’ve tried a lot to make it work but with no success…

1 Like

I’m having the issue too…This is crazy that they can release a regression that completely breaks the ability to play the game and not offer a way to downgrade or patch the game in 10 days.

It has been 8 days since my reply to this issue that everyone and myself are having. I find it pretty ridiculous that they jus had a maintenance 2 days ago and today I thought MAYBE JUS MAYBE this game would work after they had the maintenance. Sure enough the game still freezes up no matter what map or game mode I’m trying to play. Nothing works and its quite frustrating!! I know for a fact its not my computer or my windows 10. Its this game’s software thats the issue! You’d think someone would respond to us and fix this issue. but they have done nothing to fix it. therefore I definitely will NOT be purchasing the DLC content at all, im not wasting my money on a game that isn’t working!!! :rage:

Man i can’t play on the daytime or in the afternoon, i can only play in the night, otherwise my game freezes for like 45 seconds and speeds it up just to see things dead, i lost 200 points in 1x1 trying to play at different time on different days, i know how frustrating it is.

The team working in the multiplayer are the Relic bois(the guys making aoe4), probably those devs don’t even read this forums, they just get small interaction with the balance and civ design FE team, so that makes things complicated, i am not expecting a fix for that soon, in fact i would expect a new DLC first.

[IMPORTANT] Fixing the freeze at the start of the game that came with the 44725 update :: Age of Empires II: Definitive Edition General Discussions (

Anyone crashing like this can try this solution, I have posted link in a couple other topics, this completely eliminates in game crashes for me, it will reduce the performance of the game by a great deal because you are only running it on one processor core though as a consideration(very low frame rate)

1 Like

Got an email myself from the devs telling they are working on a fix.

Sadly that ain’t a proper fix, if you set affinity for one core and then try to force to execute “useallavailablecores”, that is a big contradiction.

The engine was never meant to support multi threading, latest patch is demanding a lot of power, if i unlock the frame rate the cpu usage goes to 20%, which was always below 12% no matter what, that is a big change that could be explaining the crashes.

Setting affinity to one core or thread is the same like using vsync, you are capping the game performance.

In voobly or zone or whatever platform, they game would crash when hitting 100% usage in one core/thread, for aoe2 the engine was designed to use like 90% of load in one core/thread, whenever you maxed out that core to 100% the game would crash, so i been thinking that could be causing the crashes.

a new hot fix that was released has not fixed the issue at hand, at first, the game played for a few seconds longer but that it, after that the same freezing as always.

1 Like

it’s been two weeks and i can’t still play the new dlc i bought, i’m really disappointed


It’s been 19 days, actually.

the most helpful thing you can do is reach out to our support team so they can work with you one-on-one:

Please do your best to provide the following details to them:

In the meantime, the team is looking at the information they have to determine whether there is a common cause amongst everyone: be it antivirus disruptions, game file issues, or hardware/driver issues that interfering with the launch of the game.

Will update the thread if/when I learn more!

OK so i been using Parallels VM for windows 10 on my MacBook pro connected to my original bootcamp to play AOE games. Since the new update, the game practically broke and still is and still no answer to why that is


i decided to go back to logging into WINDOWS 10 through my regular bootcamp on restart and the game works perfectly again. so strange yet so annoying. but i can play the game again now.

Hello, buddy.

So, the only thing you did was to play in windows? I’m not quite sure what you did to play again

i been using WINDOWS 10 as a virtual machine with Parallels through my macOS. it created a virtual copy of my windows 10 bootcamp. Playing AOE II DE on there is broken and the game constantly freezes up as soon as i start any type of game both skirmish and campaign.

i decided to close it all down and log into WINDOWS 10 through my original bootcamp startup disk and the game has been working perfectly fine. there no freezing up or anything.

i can’t explain exactly as to why that is

I sure hope they have a fix soon! because its driving me crazy with the crashes this game does now ever since the new DLC update happened. Now its freezing right when the map loads on the screen. so this problem is getting worse, and still no fix for this issue…

I have been playing the original AOE and its not the same as AOE 2! ugh… (starting to get bored of this problem and very frustrated!) :rage:

1 Like

Is it time to presume that this will never be fixed? Very disappointed to have bought an expansion over a month ago and not even been able to play a single game on it without crashing


I imagine that if the crashing is indelibly linked to some integral part of the expansion, then it will never be entirely fixed. They seem to have significantly changed how the game allocates system resources, and in doing so they appear to have inflated the minimum system requirements needed to run the game.

I don’t experience the issue, but one thing I would try is setting up a skirmish game with as low a population limit as possible. If the game doesn’t crash, then incrementally increase the population limit until the crash reoccurs. This might not work, but it’s worth a try.