Game freezes within first five minutes of playing any game (campaign, SP, MP)

Game Version:

  • Build (34397)
  • Platform Steam


After a few minutes (usually around 5min) of playing any game mode, whether it be MP, SP, or any campaign (I’ve tried several), the game always freezes and the only way to get out of the game is through the Task Manager. I bought this game at launch and had no problems until a day or so ago, I tried verifying my game cache and that didn’t fix the issue.

Reproduction Steps:

  1. Start up the game
  2. Start any game mode
  3. Game always freezes

Attached is my DXDIAG. Thank you.

DxDiag.txt (152.1 KB)

I’m still having this issue. I’m unable to play any game mode. The game is essentially unplayable atm. It was fine earlier this week

I just tried uninstalling/reinstalling the game. Issue still persists

I also tried uninstalling the graphics DLC. Problem persists

I unsubscribed from all mods (although none have been active anyway)

Problem still persists. Game does not generate a crash log entry since the game freezes and doesn’t actually CTD

Can someone please help me with this. It’s been three days and I haven’t heard a peep from a dev. I paid for this game and It’s literally unplayable

I also set all graphics to their lowest setting. Problem still persists

Tried booting the game from the file instead of through steam. Problem still persists

Ok so just the screen freezes. The game itself actually still continues in the background. I can hear the audio from units being made and technologies being researched. I can move my mouse and click on buttons. I get the audio of clicking on things but of course, the screen is completely frozen. I’m pretty sure the menus actually open. When I click on a menu in the top right, the game (in the background) pauses like it should but since everything is frozen, I’m not actually seeing the menu. When I click where the menu should be, I get the audio cues you get when you click buttons

Ok I solved the problem. I disconnected my second monitor and the game runs fine now with no crashes.

I love you guys and you did an awesome job with the game but it really would have been great if you had made some effort to help me out.

I look forward to see what you guys do with this game in the future. Thank you

A lot of us are facing the game crash issues and its still not fixed

1 Like

Same here. It seems that after a couple of minutes in game everything is literally not responding to any command.

Units not moving, not even switching attack stance.

Is unplayable at the moment.

Check whether you are signed into the xbox live. If you are signed in then sign out. I did this on my system and surprisingly it worked. It has not crashed yet after doing that