Game inmediatly closes

The game window opens for 3 seconds then clses, thats all

I checked if it was for some system requeriments but all it seems in order.

Windows is updated too.

I guess this about AOE DE edition. Did it run correct before already?
If not, then please post back your system details (manufacturer and model).

Hello,

Yes, it is about the definitive edition. About my computer:

  • HP Pavilion 15-p003la
  • Procesor: AMD A10-4655M with Radeon™ HD Graphics 2.00 GHz
  • Installed RAM: 8.00 GB
  • Graphic Cards: AMD Radeon ™ R7 M260 and AMD Radeon HD 7620G

Also i got an error message from the event viewer everytime i try to start the game.

Unable to start a DCOM Server: Microsoft.MSDallas_1.3.22960.2_x64__8wekyb3d8bbwe!App as Unavailable/Unavailable. The error:
“5”
Happened while starting this command:
“C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.22960.2_x64__8wekyb3d8bbwe\AoEDE.exe” -ServerName:App.AppXk5nq8fm9836s7v2wt0ddnryrptdfb1e5.mca

This is difficult to say. Your CPU is on the low end together with the memory. Also it might not detect the right GPU correctly and so it fails to start. If the M260 has dedicated 4 GB of memory but instead of that the integrated HD 7620G (which uses the same internal memory as your CPU) is used by AOE DE then your 8 GB memory could be short for 1920x1080 resolution. Your laptop screen is Full HD, correct?

The minimun system requeriments are 4GB and the recomended are 16GB, i dont really think that is a memory problem.

About the resolution my pc can go up to 1366 x 768 resolution, i dont know if it can do more. Is this game only played in 1920 x 1080 resolution?

No, other resolutions are supported too. So 1366 x 768 should be fine with your specs. Do I understand that it is a Pavilion desktop and not laptop?

Could you also post back your Windows build and version number?
Search for ‘winver’ with Cortana search glass.

It is a Pavillion laptop.

My OS is Windows 10, Version 1803, build 17134.799

Thanks for your insight and assistance @PCS70!

A few troubleshooting steps you can take:

  • Make sure you have set up your Microsoft Account with a free Xbox Live Account profile. You can do this by opening the Xbox app or by searching “Xbox” in the Start Menu.
  • Make sure your antivirus software isn’t blocking the program. You can try disabling your antivirus and firewall to see whether they are interfering with your connection.
  • VPN software reportedly can also interfere with the game launching. This is something to check if you happen to be connecting to the servers through a VPN.
  • The game might also fail to launch on Windows Insider builds. In the event that you are taking the less polished Insider builds of Windows.
  • Ensure your graphics drivers and Windows Updates are up to date. This can cause any number of issues, so make sure you’re running on all the latest drivers.

Let me know if any of those steps help you so we can try to narrow down this problem. If all of that fails, let us know if anything changed and we’ll see what else can be done!

Good luck!

1 Like

Thanks for the answer.

  • By setting up my Microsoft Account with a xbox Live ccount you mean the xbox console companion app? i have an account that recognizes AoE DE as a game.
  • About my antivirus, i turned off both my firewall and my antivirus software, but the game still closes after some seconds.
  • I dont know what a VPN software does, how can i check this?
  • Also the same for insider builds, as i said before, my OS is Windows 10, version 1803, build 17134.799. How do i check if its for a build problem?
  • Windows was updated this week into the build above.

This is what i see when i open the game, it opens a window, then, afets 2 or 3 seconds it closes.

Hi @Bacillus1990, Have you tried resetting the app in the Windows 10 Settings app? https://support.microsoft.com/en-us/help/4027498/microsoft-store-fix-problems-with-apps

Users in the past with this issue have resolved it by uninstalling and reinstalling the game from the Microsoft Store. If you are not concerned with exceeding a data cap with your ISP, I would recommend this if a repair or reset of the app does not help.

More help here: https://www.ageofempires.com/support

I resetted the application but i still the game doesnt work.

I remember having uninstalled, then installed the game, with no solution. This installation is very fresh so i dont think its about reinstalling the game, also wasting a lot of time to download it again.

In the past i remember that once this game opened, i got into the game menu, changed it to fullscreen, then closed. After that the game never opened again.

1 Like

Have you tried creating an offline user account to play the game? Sometimes user profiles in Windows 10 become corrupt.

1 Like

I logged out of the windows store and tried to enter, but still doesnt work.

Is there something to do with my event viewer?

Unable to start a DCOM Server: Microsoft.MSDallas_1.3.22960.2_x64__8wekyb3d8bbwe!App as Unavailable/Unavailable. The error:
“5”
Happened while starting this command:
“C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.22960.2_x64__8wekyb3d8bbwe\AoEDE.exe” -ServerName:App.AppXk5nq8fm9836s7v2wt0ddnryrptdfb1e5.mca

I mean, that is the game folder and this error happens everytime i try to enter in the game.

That DCOM server error was usually solved by starting another download, then pause that download, minimize the Microsoft Store and then launch AOE.

Could you also check in Microsoft Store for other updates. Just click on ‘…’ next to your profile icon and select ‘Downloads and updates’ and click ‘Get updates’ button.

Most times this related to an error or something that got stuck in the user profile. The best thing is to create a local administrator user account and sign in with that one and check if the game is working correct.

Also important to know which antivirus program is installed on your system?

The game is updated in the game store, also tried to start it with another application being in the middle of a download.

So i should make another user and try to run the game from that user?

To bad it didn’t help. Yes, please try that first. And make sure that the new local user account is configured as administrator user, not standard. After first sign in which takes a while I would first open Microsoft Store and check for updates there again, after that sign in to Microsoft Store but don’t migrate your (local) account to MS connected account. Just say no to that question if it’s asked. Then install the game from the MS store and try to launch it. It doesn’t have to download everything again as it probably is available in the MS store cache locally already. Let’s check if this helps you. Success.

Ok, i did another user, but the game doesnt install in the second user if i dont buy it, so i had to log in my first account to start the installation, as you said, the game is saved in the store cache and installation was fast, but still doesnt open.

I di a second mail and loged into ms store, game doesnt open yet. Is there something wrong with my account?

For my antivirus i use AVG, but i tried to start the game with the antivirus being deactivated.

Did you sign in to the MS store on the added new local user account with your MS account that you bought the game with?

You don’t have to buy again from local account if you use your MS account in MS store to download and install it.

I would for sure give it a try without AVG uninstalled (reboot after removal of course). If that works we can move over to the solution of adding AOE DE executable to the real-time scan exclusion list, which is different for each AV scanner.

Yes i had to do it with my MS account so the install button appears in the MS store.

I have the executable (C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.22960.2_x64__8wekyb3d8bbwe\AoEDE.exe) into the exception list of my antivirus. And the firewall have it as an exception.

But i have tried to start the game with both the firewall and the antivirus deactivated.

Sometimes deactivating AV is not enough. It should be though.

So you did manage to get the game installed below the new local user account?

I would still retry it again without AV installed. You can always reinstall it again if you kept the download and license key (or maybe it’s the free version).