Game just doesn't launch after the intro sequence

Game Version:

  • Build: dont know but it’s up to date according to Steam
  • Platform: Steam
  • Operating System: Windows 10


It’s quite simple really but it’s driving me insane : whenever I launch the game, I get to see the brief cinematic but then, nothing happens, I get sent back to Windows. As in really nothing : I mean that even when I check the logs, there’s absolutely nothing in them.
Windows says also that there’s simply nothing happening : if I check the event viewer, there’s nothing to see.
I have to think that it’s something that has to do with a recent update because when I bought it a few months ago, I was able to play the game.
I tried everything this page suggested but nothings helps, including trying to reinstall the game on a different drive.
I also tried to change my windows language to english, since it appears it helped some users with a similar issue.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Lauch the game
  2. You get to see the cinematic introduction
  3. Then nothing, you’re sent back to windows without any messages/errors


RTX 2080 ti
Intel i9 9900k
32gb ram

No solution, anyone ?