Game keeps freezing/lagging even against AI

Hi everyone,

Is anyone else experiencing major lag & freezing issues with the game even on singel player? My computer is very good and didn’t have this problem before, so must be a patch issue? Are there any fixes for this?

Is gaming mode enabled?

After starting AOE DE in full screen please press Win Flag + G to launch the Windows Game Bar and enable it if it asks to enable gaming mode.


Thanks for your reply back! I tried to enable it and restart the game afterwards but it didn’t help, I even activated game mode on my anti-virus but that didn’t help either :frowning:

I noticed on the official AoE DE stream yesterday that the commented game was freezing all the time, and I don’t even know if they consider this as normal… and none seem to care about improving this.

Maybe it’s the blood moon coming up next year. :wink:

I notice since the latest two feature updates more issues with Windows 10 in general. This might be related, didn’t play AOE DE a while. So I will test it soon and get back with my experience.

1 Like

Army stuck even against AI.
Please fix this bug!

We cannot make a better internet. I don’t think that problem is within the game itself, more internet core router related or due to the latest Windows monthly updates (again). :disappointed:

What we can do to solve a lot of the problems we experience today is to develop a much better and sustainable financial system. For that I actually need Bill Gates to join a think thank. Do you guys think he would be interested?

I know I’m thinking out of the box right now. :wink:

1 Like

I have found a simple solution which works for me -> disable the Windows Game Bar
You have to right click the Windows Button and go to Settings -> Gaming -> and just disable the game bar
Simple as that ty Microsoft