Game simply doesn't launch

Game Version: 101.101.34699.0

  • Build (####)
  • Platform - Microsof Store


Once I clicked AOE icon, i got the little loading screen then nothing happen.
Got this problem since last update.
I reinstalled the game, tried with or without antivirus, disabled firewall, nothing corrects it.
The only solution I found is to reinitialise the game, so I can launch it once… then the problem start again.

Reproduction Steps:

  1. (List the steps we can take to reproduce the bug ourselves…)




I have this exact problem.

Clicking on the game, it lauches the AoE2 DE image in the middle of the screen, which disappears in less than two seconds, then nothing.

The only way to fix this so far is to do as [CactusZebre4642] suggested: go into Windows settings, Apps, find AoE2 DE, advanced options and “Reinitialise” it. But then you also have to re-activate the HD texture pack. And of course, as soon as you restart the game, the error comes back.

This is a nightmare.

I have:

Installed last updates from game, Xbox apps, Windows itself.
Created an exception in Windows Firewall.
Updated my graphic drivers.
Used all the Windows Store tools like reinitialising the app, using the troobleshoot tools, etc.
I even spent hours trying to see if this was not a stupid DistributedCOM error that caused this.

Nothing worked.


Oh come on guys! It’s most glitchy game ever!
Confirm bug. Every time after play game you have to reset it back and after that you have to open Enchanced graphics pack in store and click “install” to validate it, wait sync process and then play.

1 Like

The only good thing is that you don’t have to download anything, so the process is very fast. But what a stupid bug…


Please, be quite. They can delete Enhanced graphics pack every time after you exit game to make process last all night :grinning:

Have you done something? When will be fixed? How long should we tolerate this?
I reset game everytime I finish. And sometimes it loose compaign progress.

Exact same issue on my side. Looking in the logs I see the following error:

Initializing Telemetry Manager
Initializing Time System
Setting Up Systems
Initializing Registry Options
Setting Program Defaults
Setting up main window
Initializing Reflect
Register Classes
Initializing Speech Synthesis
Initializing Achievement Manager
Initializing UI Widget Manager
Initializing Campaign File Type
Initializing SP Savegame File Type
Initializing MP Savegame File Type
Initializing Random Map File Type
Initializing Random Map Group Manager
Initializing Scenario File Type
Initializing Wwise Manager
Initializing Civilization
Initializing Error Handler
Initializing File System
Initializing DLC Manager
Initializing XBL System
Initializing Tool Manager
Initializing Mod Manager
Initializing Loggg System
Initializing Time System
Initializing UI System
Initializing Additional Options
Initializing Localization Manager
**Exception type 0xc0000005 occurred at 00007ff6db8c9a1f**
Writing out log

Any idea? Thanks!

I’m still at the same state actually…

Same error for me, the game wouldn’t start after the image shows.


We’d love to investigate this issue a bit more, but need your help. Can you please provide us with the BucketID and minidump file for this?

Minidump is located in the installation directory (Default Location: C:\Program Files (x86)\Steam\steamapps\common\AoE2DE) and should be updated/created anytime the Title experiences a crash, file name is “AoE2DE_s.mdmp”.


Hello ! I’ve installed it using the Game Pass / Windows store, not Steam. Where is supposed to be the dump file in that configuration?

You should find the game logs stored in two places:

  • C:\Users<WINDOWS USERNAME>\AppData\Local\age2_x1\logs
  • …\Users\UserName\Games\Age of Empires 2 DE\logs

I have the same problem after the update . I bought it from microsoft store when it launched and i can’t do nothing at all about this problem, im very pissed off about it and i want a refund but i know they will not give it to me now.

Hi there! Have you tried working through each of the troubleshooting steps in this thread to see if they work for you:

Whatever the outcome, let us know so we can follow up!

Hi, I tried a lot of the troubleshooting steps without success. My last try was to uninstall / reinstall the game multiple times, on the same disk, on another disk etc… same behavior :frowning: And now, I just cannot install it again, I receive a generic error from the Windows Store saying that an unexpected error has occurred:


Any idea?

Same here with Game Pass Version. Repair, Reinstall, Redownload, nothing.

I had the same problem before which when I downloaded the Enhanced Graphics Packs I couldn’t launch second time until I reset the application.

Today I saw all these discussions and tried to download the Enhanced Graphics Packs again. Somehow, I am okay now. I guessed the development team here saw our problem and solved the problem. Thanks development team!!

1 Like

Here is a forum post about that particular error in Windows Store. See if it may have a solution for you:

Glad to hear it’s working for you!

Thanks for the pointer. already tried it, without success :frowning: