Game wont launch after season 5 update

I played aoe4 in this laptop quiet a while and its fine, then season 5 came, made me update, now it wont launch at all, first it goes blackscreen just like the game launching and then exit

And then i tried to bought it on steam, it still the same
And then i tried reinstall my windows and aoe4, problem still same

1 Like

hello im facing excactlly the same issue please help.
AOE4 on steam, before the update everything did work.
I cant start it anymore via steam and also tried to start it as administrator from the local files.

Hello, have you solved it? I still cant play since season 5. I know this didnt happen to a lot of people, but this drives you away from the game :confused:

After this update, i can no longer play on my old ASUS Rog notebook…
It has 2x Geforce 560m on it and windows 10.
I could play normally before the update, on low graphics.

Now, on startup the game prompts a message saying i do not meet something (i don’t remember… already unistalled the game), then the game opens. The screen seems to be black, but in fact the game still is running, trying to open. Steam overload shows 1 fps, but its a lot less. This is on the opening video… i never got really into the game again…