"Go back to work" command - Bug

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 82587 (first appearance in the first April PUP, “biggest update”)
  • GAME PLATFORM: Microsoft Store and Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The “Go back to work” command (click or hotkey) at the Town Center doesn’t always work as it should. If the villagers are tasked to drop the resources they are carrying at a TC, retasked to a different resource, then garrisoned at the TC, the “Go back to work” command will send them to the second to last task instead of the last.
This bug was introduced in the first April PUP. This is a different bug than the “Town Bell” bug with which it has sometime been confused in previous reports/discussions.
This bug is very annoying, especially in the first stage of the game, when it is verry common to force the villages to drop resources to the TC.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Task a villager to collect a resource.
  2. Send the villager to a TC to drop what has been gathered (it’s not necessary that the drop happens).
  3. Task the same villager to a different resource (it’s not necessary that the new gathering starts).
  4. Garrison the villager to the TC.
  5. Send the villager back to work.

The villager will go to the second to last given task (1.) instead of the correct last one (3.).

:arrow_forward: EXPECTED RESULT

The “Go back to work” command should always send villagers to the last task assigned.

:arrow_forward: VIDEO

Bug - Go Back to Work.mp4

:arrow_forward: GAME FILES (SAVE / RECORDING)

Go Back to Work - Test.aoe2scenario (2.5 KB)
GO_BACK_TO_WORK_-_TEST.aoe2spgame (418.6 KB)
SP Replay v101.102.17051.0 #(82587) @2023.04.28 015551.aoe2record (492.1 KB)


Thank you for this detailed support! We’re now tracking this issue :slight_smile:

1 Like

Glad to help! Sorry if I didn’t report it sooner, I thought you already knew about this.

1 Like

The bug persists on Hotfix 82587.

According to the release notes the following was adressed, but i think they are fixing collateral issues and not the proper bugs:

"* Villagers no longer continue walking to Town Centers and garrison when the town bell has been activated again.

  • New sheep no longer get unintentionally killed by Villagers when ungarrisoning from the Town Center."

Hi, i also do have an issue with the “Go back to work” command after April’s “biggest update”.

Its an absolute pain. Indeed, villagers simply don’t go back to work (they remain idle) or do to the wrong task.

The bug only appears when I play online games, not skirmish…


The team is aware of the issue :slight_smile:

This bug is present in single player as well, against AI, and I don’t mean occasionally present, it completely ruins almost every game. Villagers that worked on farms, half of them go to cutting trees after clicking “send villagers back to work”. Even worse, when you pull a boar and try to last hit it by hitting the same command, villagers just ignore it and go after sheep…

Have the same problem in AOE 2 DE. Vills do not return to work after garrison. :confused: is a big pain.!

The Go Back To Work bug is the one that affects me the most currently. It’s a really important command and it is working very poorly still. Please fix ASAP!

In the May/Jun Public Update Preview this bug is fixed. So, it shouldn’t take long to see it solved in the public build.

Edit: solved with Hotfix 85614

1 Like

Most of the problems with back to work were solved with Hotfix 85614, but not all of them. There are still some vills that stay garrisoned when the back the work is pressed, on some conditions, i’m not sure why, but may be related to the resource not being available anymore. To ungarrison these vills you have to force click ungarrison. It’s annoying because you get raided, click back to work or unring the bell and some vills go back to work so you think you are ok. Only some time later when you click idle vill you realize some vills are still locked inside the town centers and need to be force ungarrisoned.


Hi @AirmailAttic719
Do you have a replay where this issue happens?

I’m not sure if i can find them, but if i don’t find i’ll post when it happens again.

Next time check here and save the rec on a safe place so I can send it to the team in order to investigate the issue :slight_smile:

C:\Users\User\Games\Age of Empires 2 DE-manynumbers-\savegame

I found a very easy way to reproduce, i don’t know if it covers all the errors remaining on back to work, but this is it:

  1. produce some vills and set them to spawn garrisoned in the tc.
  2. use back to work and check that they don’t leave the tc.
  3. put more vills inside the tc, all of them were doing nothing.
  4. use back to work and check that the vills spawned outside will go back to work and the ones spawned inside will remain there.

All vills should go out of the tc once back to work is clicked.

Recorded game is attached.
rec.aoe2record (2.3 MB)


Thank you for this detailed report, I informed the team about the issue :slight_smile:

1 Like