HALP Game Crash on Launch!

The Problem:

  • When I launch the game from Steam, I briefly see the launching splash screen and then it closes. No error messages or anything, it just crashes.

Things I’ve tried:

  • Reinstalling through steam
  • Verifying the integrity of the game files through steam.
  • Directly running the .exe as admin
  • Disabling cloud sync in Steam, manually deleting all the game files, and then reinstalling.
  • Disabling steam overlay
  • Various steam launch arguments
  • Turning the Advanced Graphics Pack on and off
    All to no effect! I launch the game, the splash screen shows for a few seconds, then crash to desktop with no error message D:

More Info:

  • AoE2DE_s product version is 101.101.34223.0
  • My PC exceeds the minimum spec requirements (i7-8700k, 16gb ram, EVGA FTW 1080 Ti)
  • Windows is up to date (Win10 Pro 64-bit, version 1909)
  • Display drivers are up to date
  • MS Visual C++ Redistributables are up to date
  • I’m not using any third-party antivirus, and disabling the Windows 10 firewalls has no effect.
  • I’ve tried using Event Viewer, but when I look under [Event Viewer (local) / Windows Logs / Application] I can’t find any relevant info at all. Maybe I’m looking in the wrong place?

Has anyone else had similar issues?
Any possible solutions or things I could try?

Thanks for your time, all the best!


I solved it!
Turns out a corrupted user file was to blame for the crash on launch.


How I identified the issue:
While looking though all the AoE 2 DE folders I discovered that the game keeps .txt logs at this location:
C:\Users[username]\Games\Age of Empires 2 DE\logs
I checked the most recent log, and after a whole bucha text I saw this:

Setting up hotkeys
Exception type 3765269347 occurred at 00007ffd5bf1a839
Writing out log

It looked like it was crashing when it tried to load the user hotkeys, so probably a corrupt .hki file. So I did a system-wide search for WHERE IN THE DARNED HECK Steam kept the user files for AoE 2 DE, and I EVENTUALLY found it here of all places:
C:\Program Files (x86)\Steam\userdata\53868183\813780\remote

So I deleted all the user files in there and VOILA, SHE BOOTS
Honestly there should be an easier option for resetting an app. Uninstalling and reinstalling the game FAILED TO DELETE THESE USER FILES, even when I had Steams Cloud Sync option turned OFF.

Holy flippen heck bud, who knew I had to channel Nancy Drew and FOLLOW THE CLUES to solve this mystery. It seems likely no one will ever read this, but nevertheless I shall leave this text here as a memorial detailing my perilous misadventures in the offchance it lends assistance to a similarly misfortuned adventurer.


1 Like