Hard AI keeps resigning

:arrow_forward: GAME INFORMATION

  • Build: 101.101.39515.00
  • Platform: Microsoft Store
  • Operating System: Windows 10
  • Gamertag: KillerzShot

:arrow_forward: ISSUE

:question: Describe the problem in detail (below). Please limit to one issue per thread.

When I play a game against hard AI it resigns when there is no apparent reason for it to. No fighting has occurred and nothing substantial has happened. The resignations usually happen just after the AI’s advance to the Feudal Age. I have added the YouTube links to 2 videos displaying the issue and there is a 3rd on that channel showing the issue.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Add 7 AI and keep their race selections random.
  2. Set the treaty length to 10 minutes.
  3. Set the population to 400.
  4. Set the map size to Giant.
  5. Set the difficulty to hard.
  6. The map selection doesn’t seem to impact the resignations.
  7. Set the game speed to Fast.
  8. Set the player to team 1 and the 2nd AI to team 1.
  9. Set 3 of the AI’s to team 2.
  10. Set 3 of the AI’s to team 3.

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE of the game where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

Does it happen on Arabia as well with the same settings or is it always on special maps or?

1 Like

Have you opened the chat box and told the AI to not resign? I think it’s lame you have to do this, as there should just be a toggle in the lobby when creating a match (a quality of life improvement). This was never 100% effective, but better chance of no resign(s) than not doing it. I don’t know if its reliability issue has been fixed yet or not…

Plus, I had another QOL improvement idea to give us a confirmation that the AI successfully acknowledges our request…

1 Like

Thanks for your response. I did try the method of opening up the chat itself, going to AI commands, and then sending 104 through the command list. The outcome has always been the same with these settings even when I send the 104 AI command. The other commands seem to work fine. I may try a re-install of the game to see if it has any impact.

1 Like

Thanks for your response. The map doesn’t seem to matter. I’ve tried standard with these settings and it’s always the same outcome. Even when sending the 104 command. I can’t seem to see anyone else having the issue apart from before a patch a few months back.

1 Like

Hello… I’ve managed to fix the problem. The issue was with the “AI Pack” Mod. It must change something in the Hard AI itself or interfere with the base AI. I had assumed it just added extra AI’s e.g. the popular Barbarian AI but alas it would appear it was the factor which was breaking my hard AI. I feel rather foolish but I’ll leave this here just in case anyone else ever runs into a similar problem. I did notice that the 104 command wasn’t responded to before I had removed the AI Pack but afterwards the command 104 appeared to work. So maybe the AI pack interfered with the AI Commands instead. Thanks for everyone’s input it was greatly appreciated.


That could be a very useful thing to know about alright.

I might test this myself.

1 Like

Glad you got it fixed! Hopefully it stays reliably working. I’ve never had 100% reliability with chat 104 command, but I haven’t done many tests recently, to be honest. It did, however, work when I tried it a week ago

1 Like