Haudenosaunee (Iroquois) advance to age II in just over 2 minutes

I don’t usually talk about balance, but what the hell is this?

I haven’t even gotten the 800 food to go to age II, and he’s already collapsing a house with his explorer. How can you play against that?

I also tried to attack him with my melee villagers, so in addition to losing collection time, it’s pretty useless if he moves to avoid being attacked. Take shelter them is also useless, since the shot barely does any damage, and you also lose collection time.

Also in case of being shot down, he is rescued through the plaza, so it doesn’t take long for him to return to lay besiege.

My rank is not high, I usually oxilate between 1080 and 1200 ELO, and if I’m doing something wrong I don’t know what it is.

These images will speak for me:

A house on the ground at minute 3:28, although it could have been earlier if I hadn’t tried to defend myself with the villagers.
Captura de pantalla (188)

And also it is already installed with the plaza and a barracks to receive shipments and create troops.

I think the Chinese/Spanish civilization could deal with this because they can create disciples/dogs, but the others have a hard time. Should I send the military card before the 3 villagers to increase the attack of the TC? It may be the only way to defend against this, but we shouldn’t rely on a card to defend against a scout. It sounds ridiculous.

this is an old cheese dating back to 2006. they have zero eco behind this you just snipe the explorer with tc fire and move on with your day


It’s what I did initially, but look at his hit points and his siege. I know that it sacrifices the economy to do this, but I also lose harvest time and wood for the house. Besides, it wouldn’t be long before he created and sent troops from the metropolis.

How do they explain this? He sent only one first age card, but apparently no second age card was sent, so ‘urban destroyer’ could not be sent.

Either it’s a hacker, or the graph is wrong.

uh, looks like some sort of inconsistency. did he have a modded deck somehow that slipped town destroyer into age 1? This makes more sense why it was so problematic for you, since normally the time the card shows up is 40s after they’ve hit age 2, where you should be aged or seconds away from it

1 Like

I don’t know what he did, but before minute 3 he had already subtracted half of the points from a house.

post the rec if you have it- even with 10/10 or no villagers making etc, the haude explorer card cant be sent before age2 like dansil said. if it was send earlier thats cheating
otherwise just shoot the turd and go age2 and smash him with better eco, or really torment him and make sure to wall around the explorer once he falls and take your time

Sorry, I didn’t save the game.

There seems to be an error, because I did the tests myself and it seems that there is a mismatch in the minute in which the age is advanced and the minute in which the shipment is made. The graph is simply wrong.

the timeline only show you when the shipment is gained, not when it is sent


Anyway there is an error because it seems to have arrived before age 2.