Hello, Game not booting. Tried all Diag tree's I couldn't find solution

Game Version: Unsure how to find.

the screen flashes changes resolution, screen goes black with mouse loading circle for about 5seconds then returns to desktop.

Win 10 22H2

  • Build ((####))


((Replace with a detailed description of the problem…))

Reproduction Steps:

  1. ((List the steps we can take to reproduce the bug ourselves…))

Bump, not working on multiple computers and accounts. It has to be the game. I assume…

On xboxs its after 9 pst and still not availble why ?

Its an old game, but probably some other issue.
Since aoe3 has nearly the same engine, may i ask, if you run the game as Admin ? ‘You can also run the game as Admin, if you start Steam as Admin’
Also, it might have issues, if your username has chinese / Japanese letters.
Let me know what you have tried so far.

1 Like

The game wont let me in . On xboxs its saying its still not available yet ?

You are looking at Age of Mythology here, not Age of Empires 2
2. Restarting your Xbox could help, or waiting a bit more, since the game gets rolled out over time, to not overload the Servers.

Thank You for the reply,

I tried to run as admin both ways presented and it did not work.

Have you tried DGVOODOO2 ?
It helps to fix old games graphic issues. Maybe its worth a shot.

1 Like

Multiple computers, multiple Windows accounts?
This means there are some corrupted files in the cloud.
Steam Client - Settings - Cloud - Enable Steam Cloud synchronization
Is this ticked?

1 Like
  1. Uninstall the game.
  2. Delete the game’s folders Steam/steamapps/common/Age of Mythology
  3. Open Steam Client - library, right click on Age of Mythology, properties, general, untick Steam Cloud
  4. Install the game again.

I haven’t better idea.

1 Like

Hello, Thank you very much for helping me out and responding to my post.

I tried applying DGVOODOO2, but there isn’t / I cant find a glide file to replace. I cannot get it to work.

When I uninstall the Game: that file path you mentioned disappears,
When i reinstall the game, it is created.
I then Deleted the file path, then verified the files, the files came back. No fix.

I really appreciate your help. Thank You again.

Hay, you replace actually nothing :smiley:
Here is a guide / Different game, but does the same: Updated tutorial for dgVoodoo2. How to get old games and apps to work on windows 10. - YouTube

Amazing the IQ of this community that this problem recurs like forever and no one even suggest he tries it.

1 Like

Trickishbook405, my apologies but i dont know how to apply the line the aomee.exe or aomx, they dont show up.

Thank you alot for the help.

Force a Video Mode
Follow these instructions to configure your video mode and resolution before launching a game:

Open Steam
Go to the "Library"
Right-click the game which needs to be reconfigured
Select "Properties..." from the menu
Go to the section "Launch Options"
Remove any launch options currently shown in the input box
Specify the appropriate Video Mode and Video Option switches from the lists below

xres=1920 yres=1080
or numbers from your current resolution on your screen

1 Like


That fixed it! Thank you for guiding me thru this and everybody else who helped. I learned a lot.

I liked the post, marked it as the solution, is there any other way to reward you?

Thanks again.

sorry, but same issue is back. it worked initially. Is there something I should do to get the game to boot up normally?

You can try to go to the actual .exe in steamapps folder, right click properties, compatibility, force it to run in compatibility (640x480 mode), and see if it boots, then try to change it in options.

Check if anything is hooking (overlays?) and see if it works with this program on / off.

1 Like


With all the info I learned in this post, i have fixed the issue, so far, i wish i could give a detailed list, but im going to write down what i remember fixed it.

  • I added the description you said in the steam launcher thing,
    -I also went into a system folder and changed windowed mode to either 1 or 0,
    -i went into steam apps launcher exe file and turned on xp service pack 2 compatibility setting.

Now everything is working greatly

I have learned so much and I can’t thank you enough for your time and knowledge. I shall pass it on.

Thanks again.