Help: GPU usage drops to 0% and screen frozes periodically

Hello everybody,

As the tittle says, when playing aoe II DE, the games freezes from 0.5 to some seconds every few seconds (more or less a minute I think). The further the game progresses, the longer the freezing. During this freezings the GPU usage drops to 0%. It only happens with this game, more resources demanding games work good. The problem happens in single and multiplayer, and with any graphical settings, from ultra to low.

My GPU is a GTX 980 and the CPU is a i7-6700k, so I don’t think it’s a CPU bottleneck bc is balanced and bc any CPU core reaches 100% usage. I have also run the Windows Memory Diagnosis Tool that hasn’t found any problem. I didn’t had the last GPU drivers. I have updated to the last ones and the behaviour is the same. My energy saving plan is High Performance and I have added aoe2 as High Performance in the Windows Graphics Configuration. I have also used RAMMap to clear cached contents in RAM.

I have also tried with the Integrated GPU, and the issue repeats with the same symptoms. But with the added peculiarity that the drops also affects slightly the CPU.

So I don’t think what more to do. The only extra thing I could try is to test with much more older GPU drivers, but it’s a little bit frustrating to use a very outdated driver only because of a single game, meanwhile more demanding games work perfectly.

Task manager screenshots with GTX 980 and intelHD: https://imgur.com/a/rtNNQh9

Best regards and thanks for your time,

Hector25E

1 Like

Here’s a support article that may help. It links to some optimization tips, and provides a link at bottom to contact support if all else fails:

 
 
 

The following thread doesn’t sound like your issue (you don’t mention rubber-banding/speeding up and you don’t have 6700XT GPU), but posting for your review. There are some troubleshooting steps I listed there (taken from an even older thread) that may or may not help…

Hello Darkness01101,

Thanks for your reply. The fisrt link I have already read it and have not worked. The second one not, but although this is the exact problem I have (rubber-banding/speeding up, I didn’t know how to describe it before, but it’s just like that) nothing from the thread has helped me.

1 Like

Hi Hector, since you have rubber-banding, maybe do what an admin says here:

And if you contact Support, I would link them to these threads, and especially GMEvangelos’ post there.

Sorry to hear nothing is working so far

Thanks you so much Darkness01101,

I will try to contact them directly.

1 Like

Did you ever figure a solution to this issue? I’ve been having the exact same issue as you have.