Histoircal battle "Bapheus (1302)" in campaign

:arrow_forward: GAME INFORMATION

  • Build: Version 101.101.40220.0 5438859
  • Platform: Steam
  • Operating System: Windows 10

:arrow_forward: ISSUE

I was playing the historical battle "Bapheus (1302) to get the Turkish Delight achievement (Win the Historical Battle “Bapheus (1302)” by defeating all other Turkish factions without forming an alliance with any of them.).

This was a long campaign, and I spent a long time playing and decided to finish of the Byzantines before finishing off the last Turkish tribe Candar (Cyan) (that I obviously had not allied with, because I was going for the achievement), and after the Byzantines had been defeated a Turkish soldier prompts and says “All enemys of the sultanate has been defeated”. This led to the campaign to end with victory, but I didn’t get the chance to kill the Candar tribe (Cyan), and I did not get the achievement, nor a chance to get it.
The “Catalan Company” (orange) had also been defeated. Only Cyan was left.

I know I can probably just play it again and defeat the tribes first, and the Byzantines last, but that’s going to take another hour of my life. I would like this bug to be fixed for future poor players who end up doing what I did.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Play the Bapheus (1302) historical battle on standard difficulty
  2. Defeat the Germiyan (yellow), Karesi (Green) and then the Byzantines (Blue). The Catalunian Company (orange) was defeated before the Byzantines were, but this happened by it self after their soldiers attacked and were all wiped out.
  3. Trigger the victory prompt before defeating the Candar (Cyan), and miss out on the achievement.
1 Like

I played this twice from scratch beating all 3 tribes first and it still didn’t work. I even tried beating them in different orders.The Turkish Delight achievement is bugged from what I can tell.


When I played it, I got the achievement with no problem back in April 2020. (In response to OP:) You have to read the wording of the Objectives very carefully. It’s very clear that the scenario ends if you destroy 3 byzantine castles, and the defeats of the other factions are optional objectives; there is no bug there. Therefore you must defeat all other players before finishing off the last castle.

Like with any long scenario facing an achievement, I suggest saving often when doing it.

Although I did this in April 2020, @AngrySmores , there could be a bug now with the steam achievement.

Edit - It looks like Smoke on the Water Achievement (Lake Poyang) Not Firing is related.

The objectives weren’t split as clear into primary and secondary objectives the time I did it. That, or my eye just wasn’t trained enough at reading that list, or seeing the difference in silver and gold. But I am pretty sure the list didn’t look like that when I did it the first time, because it is pretty clear as you say.

This bug was reported for a different build. You should re-report it with the current build if you tried twice and still didn’t get it. I, who initially reported the bug/problem, got the achievement after trying tribes before Romans.

1 Like

Same issue here, v.101.101.44834.0 6148570

Defeated all the enemies, never made an alliance, still does not unlock for me. Here is a game save and screenshots: TURKISHDELIGHT.aoe2spgame - Google Drive


It’s a important bug. They should fix it immediately.


Same here. No alliances; defeated everyone else before taking down the castles; still no achievement. This and Lake Poyang “Smoke on the Water” seem to be the only Achievements not working right now.

Turk Del win3|690x432


Just did this today beat every Turkish faction with out forming an alliance with then the won no achievement.

1 Like

Same issue.


I even destroyed Rum (purple) thinking maybe that was the problem but still no achievement

1 Like